summaryrefslogtreecommitdiff
path: root/media-sound/pms/pms-0.42_p20170508.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/pms/pms-0.42_p20170508.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/pms/pms-0.42_p20170508.ebuild')
-rw-r--r--media-sound/pms/pms-0.42_p20170508.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/pms/pms-0.42_p20170508.ebuild b/media-sound/pms/pms-0.42_p20170508.ebuild
new file mode 100644
index 000000000000..13f5072cbc92
--- /dev/null
+++ b/media-sound/pms/pms-0.42_p20170508.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils vcs-snapshot
+
+REF="8c8918488a4a22924ee04442dc5e5216783d51ff"
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="https://ambientsound.github.io/pms"
+SRC_URI="https://github.com/ambientsound/${PN}/tarball/${REF} -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+regex doc"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+ media-libs/libmpdclient
+"
+DEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/pandoc )
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOC=$(usex doc)
+ -DENABLE_REGEX=$(usex regex)
+ )
+
+ cmake-utils_src_configure
+}