summaryrefslogtreecommitdiff
path: root/media-sound/playmidi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /media-sound/playmidi/files
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'media-sound/playmidi/files')
-rw-r--r--media-sound/playmidi/files/CAN-2005-0020.patch69
-rw-r--r--media-sound/playmidi/files/playmidi-2.5-includes.patch66
-rw-r--r--media-sound/playmidi/files/playmidi-2.5.patch22
3 files changed, 0 insertions, 157 deletions
diff --git a/media-sound/playmidi/files/CAN-2005-0020.patch b/media-sound/playmidi/files/CAN-2005-0020.patch
deleted file mode 100644
index 9cd120eddb59..000000000000
--- a/media-sound/playmidi/files/CAN-2005-0020.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- playmidi.c.orig 2005-01-17 17:43:20.578060936 -0500
-+++ playmidi.c 2005-01-17 17:48:55.022217696 -0500
-@@ -22,6 +22,7 @@
- #include <ctype.h>
- #include <unistd.h>
- #include <sys/stat.h>
-+#include <errno.h>
- #include "playmidi.h"
-
- SEQ_DEFINEBUF(SEQUENCERBLOCKSIZE);
-@@ -186,6 +187,15 @@
- struct stat info;
- int piped = 0;
-
-+ /* CPhipps 2000/02/04 - this might be splaymidi, in which case we're
-+ * probably setuid root. Drop privs immediately.. io_svgalib.c can
-+ * regain them */
-+ if (getuid() != geteuid())
-+ if (seteuid(getuid())) {
-+ perror("seteuid");
-+ exit(EPERM); /* Seems appropriate */
-+ }
-+
- printf("%s Copyright (C) 1994-1997 Nathan I. Laredo,"
- " AWE32 by Takashi Iwai\n"
- "This is free software with ABSOLUTELY NO WARRANTY.\n"
-@@ -439,9 +449,9 @@
- for (i = optind; i < argc;) {
- filename = argv[i];
- if (stat(filename, &info) == -1) {
-- if ((extra = malloc(strlen(filename) + 4)) == NULL)
-+ if ((extra = malloc(strlen(filename) + 5)) == NULL)
- close_show(-1);
-- sprintf(extra, "%s.mid", filename);
-+ snprintf(extra, sizeof(extra), "%s.mid", filename);
- if (stat(extra, &info) == -1)
- close_show(-1);
- if ((mfd = fopen(extra, "r")) == NULL)
-@@ -452,7 +462,7 @@
- if (ext && strcmp(ext, ".gz") == 0) {
- char temp[1024];
- piped = 1;
-- sprintf(temp, "gzip -l %s", filename);
-+ snprintf(temp, sizeof(temp), "gzip -l %s", filename);
- if ((mfd = popen(temp, "r")) == NULL)
- close_show(-1);
- fgets(temp, sizeof(temp), mfd); /* skip 1st line */
-@@ -460,7 +470,7 @@
- strtok(temp, " "); /* compressed size */
- info.st_size = atoi(strtok(NULL, " ")); /* original size */
- pclose(mfd);
-- sprintf(temp, "gzip -d -c %s", filename);
-+ snprintf(temp, sizeof(temp), "gzip -d -c %s", filename);
- if ((mfd = popen(temp, "r")) == NULL)
- close_show(-1);
- } else if ((mfd = fopen(filename, "r")) == NULL)
---- io_svgalib.c.orig 2005-01-17 17:49:55.758984304 -0500
-+++ io_svgalib.c 2005-01-17 17:49:59.310444400 -0500
-@@ -259,6 +259,10 @@
- tcgetattr(mytty, &newtty);
- newtty.c_lflag &= ~(ICANON | ECHO | ICRNL | ISIG);
- tcsetattr(mytty, TCSANOW, &newtty);
-+ /* CPhipps 2000/02/04 - restore euid root in order to start SVGALib.
-+ * We don't have to worry about errors, or dropping priv's afterwards,
-+ * SVGALib handles that safely for us. */
-+ seteuid(0);
- vga_init();
- if ((vgamode = vga_getdefaultmode()) == -1)
- vgamode = G640x480x256;
diff --git a/media-sound/playmidi/files/playmidi-2.5-includes.patch b/media-sound/playmidi/files/playmidi-2.5-includes.patch
deleted file mode 100644
index 0a93c5930892..000000000000
--- a/media-sound/playmidi/files/playmidi-2.5-includes.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -ur playmidi-2.4.orig/Makefile playmidi-2.4/Makefile
---- playmidi-2.4.orig/Makefile 1998-10-01 05:39:18.000000000 +0300
-+++ playmidi-2.4/Makefile 2007-07-25 16:22:23.000000000 +0300
-@@ -12,38 +12,38 @@
-
- # ncurses usually /usr/lib, -L/usr/local/lib doesn't hurt
- # unless there's more than one ncurses floating around on your system
--LIBNC = -L/usr/local/lib -lncurses
-+LIBNC = -L/usr/lib -lncurses
-
- ######### NOTE: X11R6 or newer REQUIRED
--LIBX11 = -L/usr/X11R6/lib -lXaw -lXmu -lXt -lX11 -lXext -lSM -lICE
--LIBGTK = -L/usr/X11R6/lib -lgtk-1.1 -lgdk-1.1 -lglib-1.1 -lX11 -lXext -lm
--LIBVGA = -L/usr/local/lib -lvgagl -lvga
-+LIBX11 = -L/usr/lib -lXaw -lXmu -lXt -lX11 -lXext -lSM -lICE
-+LIBGTK = -L/usr/lib -lgtk-1.1 -lgdk-1.1 -lglib-1.1 -lX11 -lXext -lm
-+LIBVGA = -L/usr/lib -lvgagl -lvga
-
- # ncurses is usually in /usr/include/ncurses, but you may need
- # to use /usr/local/include/ncurses depending on your setup.
- INCNC = -I/usr/include/ncurses
-
- # just in case you keep your X includes in an odd location.
--INCX11 = -I/usr/X11R6/include -DNARROWPROTO
-+INCX11 = -I/usr/include -DNARROWPROTO
-
- # stuff for sound blaster awe32
- INCAWE = -DVOXWARE_CONTROLLER_7_WORKING
- # awe_voice.h path
--INCAWE += -I/usr/lib/oss/include/sys
-+INCAWE += -I.
-
- # usually in /usr/include, but -I/usr/local/include doesn't hurt
- # unless there's more than one svgalib floating around your system.
--INCVGA = -I/usr/local/include
-+INCVGA = -I/usr/include
-
- # Directory where application defaults files are stored for X11 version
--XAPPDEFAULTS = /usr/X11R6/lib/X11/app-defaults
-+XAPPDEFAULTS = /usr/share/X11/app-defaults
-
- INCLUDES= $(INCNC) $(INCX11) $(INCVGA) $(INCAWE)
- INSTALLDIR = /usr/bin
- INSTALL = install -s
-
- # if you are using the GUS Ultra driver module, add -DULTRA_DRIVER
--CFLAGS = -Wall -pipe -fomit-frame-pointer -O2 -m486 $(INCAWE)
-+CFLAGS = -Wall $(INCAWE)
- LDFLAGS =
-
- OBJECTS = playmidi.o readmidi.o playevents.o \
-diff -ur playmidi-2.4.orig/playmidi.h-dist playmidi-2.4/playmidi.h-dist
---- playmidi-2.4.orig/playmidi.h-dist 1997-05-12 00:26:36.000000000 +0300
-+++ playmidi-2.4/playmidi.h-dist 2007-07-25 16:22:44.000000000 +0300
-@@ -52,11 +52,7 @@
- #include <stdlib.h>
- #include <sys/soundcard.h>
- #include <sys/ioctl.h>
--#ifdef linux
--#include <linux/awe_voice.h>
--#else
- #include <awe_voice.h>
--#endif
-
- struct chanstate {
- int program;
diff --git a/media-sound/playmidi/files/playmidi-2.5.patch b/media-sound/playmidi/files/playmidi-2.5.patch
deleted file mode 100644
index 317b5c8734b7..000000000000
--- a/media-sound/playmidi/files/playmidi-2.5.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- io_ncurses.c.orig 2003-11-30 19:23:34.000000000 -0800
-+++ io_ncurses.c 2003-11-30 19:23:46.000000000 -0800
-@@ -14,11 +14,7 @@
- Kelly Drive, Lackland AFB, TX 78236-5128, USA.
- *************************************************************************/
- #include "playmidi.h"
--#ifdef linux
--#include <ncurses/curses.h>
--#else
- #include <ncurses.h>
--#endif
- #include "gsvoices.h"
- #include <sys/time.h>
- #include <unistd.h>
---- playmidi.h-dist.orig 2003-11-30 19:49:35.000000000 -0800
-+++ playmidi.h-dist 2003-11-30 19:49:46.000000000 -0800
-@@ -1,4 +1,4 @@
--#define RELEASE "Playmidi 2.4"
-+#define RELEASE "Playmidi 2.5"
- /************************************************************************
- playmidi.h -- defines and structures for use by playmidi package
-