summaryrefslogtreecommitdiff
path: root/media-sound/playerctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 07:43:56 +0100
commitb978efa000250668b2befa4e2cc96e0afa137611 (patch)
tree0c561efed9b15c17a9d3ef926443f35c58dfb48c /media-sound/playerctl
parentfa5e8e92d94ea9de5d49a1f5ad19abf7272503d0 (diff)
gentoo auto-resync : 17:06:2023 - 07:43:56
Diffstat (limited to 'media-sound/playerctl')
-rw-r--r--media-sound/playerctl/Manifest1
-rw-r--r--media-sound/playerctl/playerctl-2.4.1-r1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/media-sound/playerctl/Manifest b/media-sound/playerctl/Manifest
index b98670f4d56c..2af1be06f5c2 100644
--- a/media-sound/playerctl/Manifest
+++ b/media-sound/playerctl/Manifest
@@ -1,5 +1,6 @@
DIST playerctl-2.3.1.tar.gz 73595 BLAKE2B d6d60d82fb0a8951fba4a3de91ff1e3f4bdba7177563b65b2da53525af4ca40f42755c577f652aaa24d2de308f56a495c8f87840ad67d6cda840cba1411abdb0 SHA512 06a10d193c83f60a9a9c50dddfb0a74e00be8cde34ddaa9d75582b7ce487ac564d1ff0675f6cb0c27d968e7d435b6a427818ac14e0cdd94b86af8f5d89661a93
DIST playerctl-2.4.1.tar.gz 77371 BLAKE2B ae9f691d714d6235bd7dc3e3d9a2ed21190482bd2aa8642c108ade0c09902ccb20196d0180ed3b1ffe680ca4e6a4ee293de1a6f10d54878589e3d8c81ca81c53 SHA512 2d84f657b07c948cd6990d9e79c4eb6e83f97c387ac53c2322fc0adbeb853950fa935332233329e7555db7d157f3ced6498cc102edaffd78849ca1f7d4c49bdc
EBUILD playerctl-2.3.1.ebuild 1202 BLAKE2B a6aa753d25f13e67f3c07ad2c84eb5a8cfca681fdf79b104697e775495fdcd79834a0f455bf9975713768e15b37c3d895468f897dc58dcb5cb6501f9fc1d7542 SHA512 d542fecca06ef234072c715be3ccca5771864eeb05112750ac30376e95655e4833d6fe1d44f060a4f556b853f1d27f7cfdc956f1179ac1a0f3639a8eba33b418
+EBUILD playerctl-2.4.1-r1.ebuild 2361 BLAKE2B 8af9d735a9d2e7d818dea55fdeff55816bada0ee1e9476a8a5e6b0db18eacf271de759bc85cc9c99c467f2b1e821570d3da6f0c83c2581ea12555fca38fcbc34 SHA512 bb586f4b92f0f084844fc6ba23e5056553109e34ffb53462fa34d1532245ad57f5825462d626f3ba27457fa0a5c4aa41d298e6623b6f653117f29da9b14179e6
EBUILD playerctl-2.4.1.ebuild 1212 BLAKE2B a4e2c1675096a87e8c44b3d9bd48a71f5f5da1fb9a2ddc8205b97cc4b4c463017d7639c99a5a7e0f688ac493e05dbf0dca3f3fa8a1dcaae62ffe35d820872c65 SHA512 fdaea7744cac060bc85b341f738a16c8ec5d5fb5681f96bd9a38f106f8c1e994f176e41b1ed56fea547a3d6f5973521ce1e2c74a5b8d6aec09f3ffa77bfbc9eb
MISC metadata.xml 344 BLAKE2B 291e21642ebc0aed630579a079c007dc54669960a8b2e68f8a62f199a1cf308f0d020118fedfbd5693010d2de61f1c7b6488acf720508422493cf3e83f1ac466 SHA512 d7df9fd6e2a27888c608dd8a39461145489bbaef13fe83d0bde941adba3a496106b62ae33562a89bbb0dfa718785104f57a11fba3cc73a18edbeb5990a7c6a5f
diff --git a/media-sound/playerctl/playerctl-2.4.1-r1.ebuild b/media-sound/playerctl/playerctl-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..e1337e2c4146
--- /dev/null
+++ b/media-sound/playerctl/playerctl-2.4.1-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit bash-completion-r1 meson python-any-r1 virtualx xdg-utils
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc introspection test"
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+ test? (
+ ${PYTHON_DEPS}
+ sys-apps/dbus
+ $(python_gen_any_dep '
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Requires a lenient dbus config systemwide
+ # See test/data/dbus-system.conf and how its used in Dockerfile
+ "test/test_basics.py::test_system_list_players"
+ # Daemon tests are inconsistent, occasional failure occurs in upstream CI as well.
+ "test/test_daemon.py"
+)
+
+python_check_deps() {
+ python_has_version \
+ "dev-python/dbus-next[${PYTHON_USEDEP}]" \
+ "dev-python/pytest[${PYTHON_USEDEP}]" \
+ "dev-python/pytest-asyncio[${PYTHON_USEDEP}]" \
+ "dev-python/pytest-timeout[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddatadir=share
+ -Dbindir=bin
+ -Dbash-completions=false
+ -Dzsh-completions=false
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+
+ xdg_environment_reset # bug #596166
+ meson_src_configure
+}
+
+src_test() {
+ local dbus_params=(
+ $(dbus-daemon --session --print-address --fork --print-pid)
+ )
+ local -x DBUS_SESSION_BUS_ADDRESS=${dbus_params[0]}
+
+ export PATH="${BUILD_DIR}/playerctl/:${PATH}"
+
+ virtx epytest
+
+ kill "${dbus_params[1]}" || die
+}
+
+src_install() {
+ meson_src_install
+
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+
+ newbashcomp data/playerctl.bash "${PN}"
+ insinto /usr/share/zsh/site-functions
+ newins data/playerctl.zsh _playerctl
+}