summaryrefslogtreecommitdiff
path: root/media-sound/pithos
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /media-sound/pithos
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'media-sound/pithos')
-rw-r--r--media-sound/pithos/Manifest2
-rw-r--r--media-sound/pithos/pithos-1.6.0.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/pithos/Manifest b/media-sound/pithos/Manifest
index a8af63a59c16..8f65892875ba 100644
--- a/media-sound/pithos/Manifest
+++ b/media-sound/pithos/Manifest
@@ -1,4 +1,6 @@
AUX pithos-1.5.0-tests.patch 730 BLAKE2B fbd1613c2c3e38a6acefd215e35babd9a6f41aac6fdb492b51e0d1285eac3b2441f3323206282acd8c72bb33dcd9b80c5a8d0fd53e478df9445f6d42ae4392ae SHA512 a50e0929f9a19cca0e2d7e888d5ac228ba820ff58c7d71e08b57f92394e7913bf9bf02e5ae2de736df4b69621c913b07bf6baf14ecc9aaee3e5df921965d70ea
DIST pithos-1.5.1.tar.gz 123504 BLAKE2B fc7cd51fd773989b5734d7bfcea674c622b3c9e5072d8ae65ed724476a025802f08916c533ea6c338e748aaf5fcce595ff352b0bae6c72dc074de2afaddbb737 SHA512 43841194d0a3c3df9dd98b819c8a1e30862ebd49aad8ba4f92e91cc7e680fba97159b70748f4042737d5e399bda64cd16d6e9f6d0e29136350c78be57474442e
+DIST pithos-1.6.0.tar.gz 122025 BLAKE2B c621fe58998790f0eb0159d29c40ac4abf2feff2be790c12008be86387bf628b170e3256c2f3ac83e9b2be254d96d4aa7e3e56ac780b0d59a446d0e158d96d15 SHA512 9e7b1d1456a769882a58639bf93194ec0228d21b7b7d1404224346016532620bb862e7d79a2c741d8ef44238c22741e4fd67bc22eadc8d207818a0ece33411ab
EBUILD pithos-1.5.1-r1.ebuild 1639 BLAKE2B 9e4a9615f878b09e1f094bf521578f94405178b2094768a88c43ad93366bbb2aa7b8dae204aa90fcaafcf76b17e86c97025455bcc2a879471b7ff65c6c3a353e SHA512 8e261723904948dd312ff28ddb8a428ac9dc56bae72c0b2a4cfd2e2b33694d3b2e611f5559069bac52c2f088aba314e6181406d50f62b00b4d874edf0c824a2b
+EBUILD pithos-1.6.0.ebuild 1545 BLAKE2B f883241547087ea7383bbc12e44c2e34ee86b1656db7fde1d3151bc9e91ed6e45dc4f05f44be3415cc20980eede48d0e0400cb9d2feedc02ad156355a5b184e9 SHA512 16240602fb4f0fadfc51ffdf7be44f0ea30cc1314a56ba356db999147f155b287dda55792d34e4757c092965ff79bad57732d860647102762eeddd189977d468
MISC metadata.xml 419 BLAKE2B 9e01f2ec478f85435261e38e84ee433d9712c7d595979c916af2d2c01a5954ec0f721b0170fb32109d6a98dbef358d8f63e00a1908c6c5f38b183eb6a0e0882a SHA512 3bf8a538a46181b7ba52f20832237a119a87aaa588a7a75a0a1d881a64110805427f27a25d4f8277ec249b40218b21d291cdb21c98616a57396d0ae20b6345c9
diff --git a/media-sound/pithos/pithos-1.6.0.ebuild b/media-sound/pithos/pithos-1.6.0.ebuild
new file mode 100644
index 000000000000..2472235faa25
--- /dev/null
+++ b/media-sound/pithos/pithos-1.6.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit xdg meson gnome2-utils virtualx python-r1
+
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="https://pithos.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="appindicator +keybinder libnotify test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ app-crypt/libsecret[introspection]
+ dev-libs/appstream-glib[introspection]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/gnome-icon-theme-symbolic
+ appindicator? ( dev-libs/libdbusmenu[gtk3,introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )
+ libnotify? ( x11-libs/libnotify[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-libs/glib:2
+ dev-util/desktop-file-utils
+ )
+"
+
+src_configure() {
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ virtx python_foreach_impl meson_src_test
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}