summaryrefslogtreecommitdiff
path: root/media-sound/pithos
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
commitbc4457d8e0e53a2e43c4254d08053ba9708663e1 (patch)
tree4f8809f23d683eed73ef800d99ce7aa628a82527 /media-sound/pithos
parent5f593f75391c28294f0dffa4dd1df280a4d8df73 (diff)
gentoo auto-resync : 20:06:2023 - 01:14:49
Diffstat (limited to 'media-sound/pithos')
-rw-r--r--media-sound/pithos/Manifest1
-rw-r--r--media-sound/pithos/pithos-1.6.1-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/pithos/Manifest b/media-sound/pithos/Manifest
index e8503b8f9e64..edd1d4601ec2 100644
--- a/media-sound/pithos/Manifest
+++ b/media-sound/pithos/Manifest
@@ -1,5 +1,6 @@
DIST pithos-1.6.0.tar.gz 122025 BLAKE2B c621fe58998790f0eb0159d29c40ac4abf2feff2be790c12008be86387bf628b170e3256c2f3ac83e9b2be254d96d4aa7e3e56ac780b0d59a446d0e158d96d15 SHA512 9e7b1d1456a769882a58639bf93194ec0228d21b7b7d1404224346016532620bb862e7d79a2c741d8ef44238c22741e4fd67bc22eadc8d207818a0ece33411ab
DIST pithos-1.6.1.tar.xz 99552 BLAKE2B 048071e4c1df0cf517de64fa19cbe589972c8a34eea2f068c7d183726523c633ce36cc87344e13a8bb31d6aa4a08365b1e9691e822e5d9a7224c318dbfd7df1e SHA512 e1a13d2c789e40bf135ed551d06dfe44bf948bfe84a8bbb3f4afcab70bbcdc4f1d3f82d25f5e8d930888dd6fa04795fa2d9d47515d4199647be854c9c4a84591
EBUILD pithos-1.6.0.ebuild 1545 BLAKE2B f883241547087ea7383bbc12e44c2e34ee86b1656db7fde1d3151bc9e91ed6e45dc4f05f44be3415cc20980eede48d0e0400cb9d2feedc02ad156355a5b184e9 SHA512 16240602fb4f0fadfc51ffdf7be44f0ea30cc1314a56ba356db999147f155b287dda55792d34e4757c092965ff79bad57732d860647102762eeddd189977d468
+EBUILD pithos-1.6.1-r1.ebuild 1541 BLAKE2B a57907485b0ac40c989c6e24d6e5709331fa655eac5605162ebb357c203d5c4df5595b70e461aa0a05cbce64d1cd164c4d3025f0fa729d47d31c28a08e28b458 SHA512 90f63a687e8fa3d01826674b679fbf0c7b6fc9cec6b3d144ee4b4207624c9180139d018ce01e9b1f60e1489a2d009a9b4a664c114172dbebe621e5ed1598288f
EBUILD pithos-1.6.1.ebuild 1548 BLAKE2B d44e1e384ceadabbc7ad813b1e9bc3b619b04778034ac43ca19eee56d6f1ea7bbaafb2591ec633d0edb9889b8c9399222ed11905cd0cb1174a4bff6deb7730f7 SHA512 d32c8834393d616f4b6428a16e28421c002b57b17a0b88bea8983d0d8bce6565f82c2ad94bc9eb0d20591620c8b3dbe8e568805e1ee6246fdddbeb52a9cce98f
MISC metadata.xml 419 BLAKE2B 9e01f2ec478f85435261e38e84ee433d9712c7d595979c916af2d2c01a5954ec0f721b0170fb32109d6a98dbef358d8f63e00a1908c6c5f38b183eb6a0e0882a SHA512 3bf8a538a46181b7ba52f20832237a119a87aaa588a7a75a0a1d881a64110805427f27a25d4f8277ec249b40218b21d291cdb21c98616a57396d0ae20b6345c9
diff --git a/media-sound/pithos/pithos-1.6.1-r1.ebuild b/media-sound/pithos/pithos-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..d6115fadc61b
--- /dev/null
+++ b/media-sound/pithos/pithos-1.6.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit xdg meson gnome2-utils virtualx python-r1
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="https://pithos.github.io/"
+SRC_URI="https://github.com/pithos/pithos/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="appindicator +keybinder libnotify test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ app-crypt/libsecret[introspection]
+ dev-libs/appstream-glib[introspection]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/hicolor-icon-theme
+ appindicator? ( dev-libs/libdbusmenu[gtk3,introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )
+ libnotify? ( x11-libs/libnotify[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-libs/glib:2
+ dev-util/desktop-file-utils
+ )
+"
+
+src_configure() {
+ python_foreach_impl meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ virtx python_foreach_impl meson_src_test
+}
+
+src_install() {
+ python_foreach_impl meson_src_install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}