summaryrefslogtreecommitdiff
path: root/media-sound/pitchtune/pitchtune-0.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/pitchtune/pitchtune-0.0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/pitchtune/pitchtune-0.0.4.ebuild')
-rw-r--r--media-sound/pitchtune/pitchtune-0.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/pitchtune/pitchtune-0.0.4.ebuild b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
new file mode 100644
index 000000000000..480bbb1f29df
--- /dev/null
+++ b/media-sound/pitchtune/pitchtune-0.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Precise Instrument Tweaking for Crispy Harmony - tuner"
+HOMEPAGE="https://sourceforge.net/projects/pitchtune/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ media-libs/alsa-lib
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS README REQUIRED TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.4-lm.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doicon pixmaps/${PN}.xpm
+ make_desktop_entry ${PN} Pitchtune
+}