summaryrefslogtreecommitdiff
path: root/media-sound/picard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 08:42:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 08:42:42 +0100
commit4c4bbf21230bd972cf759b2a40b782aa4149fc1f (patch)
treea59d84c4fdbf92f79a7545ab2aa28896f6a714e1 /media-sound/picard
parente7f37e03b952768321c8c943a80eff4152ea7bbd (diff)
gentoo auto-resync : 22:08:2022 - 08:42:42
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/Manifest4
-rw-r--r--media-sound/picard/picard-2.8.3.ebuild64
-rw-r--r--media-sound/picard/picard-9999.ebuild2
3 files changed, 68 insertions, 2 deletions
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
index 5a9d74687b03..eb780aa972bc 100644
--- a/media-sound/picard/Manifest
+++ b/media-sound/picard/Manifest
@@ -1,4 +1,6 @@
DIST picard-2.8.2.tar.gz 5095347 BLAKE2B ddaab9e7d09bd7848d55ac385cd901b5f7b3e2044811cd63b16027159586e01028f2885202c4d2bbfa20926305e110e075778f0b907ff8812c937fe0905a8fef SHA512 18b4ebc6e898f4e2910d4d022a12c0516030133318467c38a77325ce088a9dd632d3d8105944570f75b918d3f4dc32b1a501e93bc92a7315ec9ff35ed3e56699
+DIST picard-2.8.3.tar.gz 5098160 BLAKE2B 5f7290de8faee502f3a4984e0080409a31f9971428da635fb79a9f2ec540d71a256584010d747de77c86e85cd58df929e8ddaa09840ebc2c17e5cdbb035c5d68 SHA512 b87e768f0f13e1e306279f71004b5ffaebb2cfc44be23f041d9193432bdc631c4a2b893d72b47109b06c450d6ff4e2b0a70c2a4b0cc5d1608a4481d26526b0e3
EBUILD picard-2.8.2.ebuild 1448 BLAKE2B 694d79f9a133a075eeaa985e500600e2310e45e7671285303f96c02a5a78d7a7c44df9e99b9851842f338f1dea5dccf8e2c1a193d09f8960f3c9ad41275b891f SHA512 aaa97fddb14ab0500dce3533314c8ebe3892b7a8a0a4741e29bb83e99e7be5e7c32c77a14bcb5130888d1a9170ba5155086fe148d046e8dfb0c9b0eb6a78332b
-EBUILD picard-9999.ebuild 1450 BLAKE2B ef2f46ea8d3fcc2d59ba7de0265d8780c1c1fc02cc7c3a03456cf89ef710604372c21c39c85742c328ac6fad55fab55a6a37649f6e6416998abc1047596b1479 SHA512 4173a90be211aa96379eb0121cd2bd04ebbafe619146b1525f362c98eac979d71ba37db9022245378c2c8ec9b3491cab6a292c8bfe42e403745afed12dc3685c
+EBUILD picard-2.8.3.ebuild 1450 BLAKE2B 80a78442f2b442fb7998d31b4799c995b12f0a504174f3c2dad9f8ca4a17b86a71cf1ab668c7a65cf3e995b1c67db4bb58095ab01eb42addd49939f911e20884 SHA512 b58c87fa1f4f971ac5ca759abb8c67b441f9df4fc492e69dc64920c4c09c0d2b12ec93cb7cf644a3444a36823e177b37bf3019e87af144a01c61281d689f0d5f
+EBUILD picard-9999.ebuild 1450 BLAKE2B 80a78442f2b442fb7998d31b4799c995b12f0a504174f3c2dad9f8ca4a17b86a71cf1ab668c7a65cf3e995b1c67db4bb58095ab01eb42addd49939f911e20884 SHA512 b58c87fa1f4f971ac5ca759abb8c67b441f9df4fc492e69dc64920c4c09c0d2b12ec93cb7cf644a3444a36823e177b37bf3019e87af144a01c61281d689f0d5f
MISC metadata.xml 740 BLAKE2B cc09a7bf012e0b85ff55531ace5d8b187cd68fdae7d274cb640a7ae446296c2ac70bb599955d6ab2570b3eb879c28cad0cf2e70fe7339c2c0c58fd8b0dcdcac7 SHA512 321188fd4887593a3683b2c507673baa9e2faf2b46b0158338a67e72dbf5267b93c1e358ceadeacd707d6a6bb234a4fae8ef681779463c4ab5bd3b79dbd47c43
diff --git a/media-sound/picard/picard-2.8.3.ebuild b/media-sound/picard/picard-2.8.3.ebuild
new file mode 100644
index 000000000000..e50d604072d8
--- /dev/null
+++ b/media-sound/picard/picard-2.8.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/metabrainz/picard"
+ inherit git-r3
+else
+ SRC_URI="https://musicbrainz.osuosl.org/pub/musicbrainz/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}"
+fi
+
+DESCRIPTION="Cross-platform music tagger"
+HOMEPAGE="https://picard.musicbrainz.org"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="discid fingerprints nls"
+
+BDEPEND="
+ nls? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ discid? ( dev-python/python-discid[${PYTHON_USEDEP}] )
+ ')
+ fingerprints? ( media-libs/chromaprint[tools] )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local build_args=(
+ --disable-autoupdate
+ )
+ if ! use nls; then
+ build_args+=( --disable-locales )
+ fi
+ distutils-r1_python_compile ${build_args[@]}
+}
+
+python_install() {
+ local install_args=(
+ --disable-autoupdate
+ --skip-build
+ )
+ if ! use nls; then
+ install_args+=( --disable-locales )
+ fi
+ distutils-r1_python_install ${install_args[@]}
+}
diff --git a/media-sound/picard/picard-9999.ebuild b/media-sound/picard/picard-9999.ebuild
index 5e3533bb35fe..e50d604072d8 100644
--- a/media-sound/picard/picard-9999.ebuild
+++ b/media-sound/picard/picard-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 xdg