summaryrefslogtreecommitdiff
path: root/media-sound/peercast/peercast-0.1218-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/peercast/peercast-0.1218-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/peercast/peercast-0.1218-r2.ebuild')
-rw-r--r--media-sound/peercast/peercast-0.1218-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/peercast/peercast-0.1218-r2.ebuild b/media-sound/peercast/peercast-0.1218-r2.ebuild
new file mode 100644
index 000000000000..105d18390306
--- /dev/null
+++ b/media-sound/peercast/peercast-0.1218-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A client and server for Peercast P2P-radio network"
+HOMEPAGE="http://www.peercast.org"
+SRC_URI="http://www.peercast.org/src/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2008-2040.patch \
+ "${FILESDIR}"/${PN}-0.1216-makefile.patch \
+ "${FILESDIR}"/${PN}-0.1216-amd64.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
+src_compile() {
+ append-ldflags -pthread
+
+ cd ui/linux
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" LDFLAGS="${LDFLAGS}" \
+ LD="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ dosbin ui/linux/peercast
+
+ insinto /usr/share/peercast
+ doins -r ui/html
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "Start Peercast with '/etc/init.d/peercast start' and point your"
+ elog "webbrowser to 'http://localhost:7144' to start using Peercast."
+ elog
+ elog "You can also run 'rc-update add peercast default' to make Peercast"
+ elog "start at boot."
+}