summaryrefslogtreecommitdiff
path: root/media-sound/paprefs/paprefs-0.9.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/paprefs/paprefs-0.9.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/paprefs/paprefs-0.9.10.ebuild')
-rw-r--r--media-sound/paprefs/paprefs-0.9.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/paprefs/paprefs-0.9.10.ebuild b/media-sound/paprefs/paprefs-0.9.10.ebuild
new file mode 100644
index 000000000000..fb32deaf5096
--- /dev/null
+++ b/media-sound/paprefs/paprefs-0.9.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit flag-o-matic
+
+DESCRIPTION="PulseAudio Preferences, configuration dialog for PulseAudio"
+HOMEPAGE="https://freedesktop.org/software/pulseaudio/paprefs"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="nls"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-cpp/libglademm:2.4
+ >=dev-cpp/gconfmm-2.6
+ >=dev-libs/libsigc++-2.2:2
+ media-sound/pulseaudio[glib,gnome]
+ || ( x11-themes/tango-icon-theme x11-themes/adwaita-icon-theme )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ dev-util/intltool )
+ virtual/pkgconfig"
+
+src_configure() {
+ append-cxxflags -std=c++11 #568590
+ econf \
+ --disable-dependency-tracking \
+ --disable-lynx \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dohtml -r doc
+}