summaryrefslogtreecommitdiff
path: root/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /media-sound/ncmpcpp/ncmpcpp-9999.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'media-sound/ncmpcpp/ncmpcpp-9999.ebuild')
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
index 74f29afe4abf..8ecc1ec6cb42 100644
--- a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
+++ b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools git-r3
+
+inherit autotools flag-o-matic git-r3
DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
HOMEPAGE="https://ncmpcpp.rybczak.net/ https://github.com/ncmpcpp/ncmpcpp"
@@ -11,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="clock outputs taglib visualizer"
+IUSE="clock lto outputs taglib visualizer"
RDEPEND="
!dev-libs/boost:0/1.57.0
@@ -39,10 +40,13 @@ src_prepare() {
}
src_configure() {
+ filter-flags '-flto*'
+
econf \
$(use_enable clock) \
$(use_enable outputs) \
$(use_enable visualizer) \
+ $(use_with lto) \
$(use_with taglib) \
$(use_with visualizer fftw)
}