summaryrefslogtreecommitdiff
path: root/media-sound/mt-daapd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /media-sound/mt-daapd/files
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'media-sound/mt-daapd/files')
-rw-r--r--media-sound/mt-daapd/files/mt-daapd-0.2.4.2-clang16.patch80
-rw-r--r--media-sound/mt-daapd/files/mt-daapd-0.2.4.2-musl.patch32
-rw-r--r--media-sound/mt-daapd/files/mt-daapd.tmpfiles1
3 files changed, 113 insertions, 0 deletions
diff --git a/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-clang16.patch b/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-clang16.patch
new file mode 100644
index 000000000000..3380cc0da44a
--- /dev/null
+++ b/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-clang16.patch
@@ -0,0 +1,80 @@
+https://bugs.gentoo.org/860879
+https://bugs.gentoo.org/875011
+--- a/configure.in
++++ b/configure.in
+@@ -21,6 +21,9 @@ CPPFLAGS="${CPPFLAGS} -g"
+
+ AM_MAINTAINER_MODE
+
++# For strcasestr
++AC_USE_SYSTEM_EXTENSIONS
++
+ dnl fix freebsd's broken (?) libpthread
+ AC_CHECK_LIB(c_r,pthread_creat,THREAD_LIBS="-lc_r", [
+ AC_CHECK_LIB(pthread,pthread_create,THREAD_LIBS="-lpthread") ])
+--- a/src/configfile.c
++++ b/src/configfile.c
+@@ -48,6 +48,7 @@
+ #include <sys/wait.h>
+
+ #include "configfile.h"
++#include "db-memory.h"
+ #include "err.h"
+
+ #ifndef WITHOUT_MDNS
+--- a/src/dynamic-art.c
++++ b/src/dynamic-art.c
+@@ -32,6 +32,7 @@
+ #include <sys/stat.h>
+
+ #include "configfile.h"
++#include "dynamic-art.h"
+ #include "err.h"
+ #include "playlist.h"
+ #include "restart.h"
+--- a/src/mp3-scanner.h
++++ b/src/mp3-scanner.h
+@@ -74,5 +74,6 @@ extern void make_composite_tags(MP3FILE *song);
+
+ /* this should be refactored out of here... */
+ extern off_t aac_drilltoatom(FILE *aac_fp, char *atom_path, unsigned int *atom_length);
++extern long scan_aac_findatom(FILE *fin, long max_offset, char *which_atom, int *atom_size);
+
+ #endif /* _MP3_SCANNER_H_ */
+--- a/src/parser.y
++++ b/src/parser.y
+@@ -26,11 +26,14 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <time.h>
+ #include "playlist.h"
+
++#define YYPARSE_PARAM
+ #define YYERROR_VERBOSE 1
+
+ extern int yyerror(char *msg);
++extern int yylex(void);
+
+ /* Forwards */
+
+--- a/src/query.c
++++ b/src/query.c
+@@ -2,6 +2,7 @@
+ #include "config.h"
+ #endif
+
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+--- a/src/webserver.c
++++ b/src/webserver.c
+@@ -41,6 +41,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
++#include "configfile.h"
+ #include "err.h"
+ #include "webserver.h"
+
diff --git a/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-musl.patch b/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-musl.patch
new file mode 100644
index 000000000000..707b7ac3b828
--- /dev/null
+++ b/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-musl.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/716010
+--- a/src/mp3-scanner.c
++++ b/src/mp3-scanner.c
+@@ -378,7 +378,7 @@ int scan_init(char *path) {
+ */
+ int scan_path(char *path) {
+ DIR *current_dir;
+- char de[sizeof(struct dirent) + MAXNAMLEN + 1]; /* overcommit for solaris */
++ char de[sizeof(struct dirent) + NAME_MAX + 1]; /* overcommit for solaris */
+ struct dirent *pde;
+ int err;
+ char mp3_path[PATH_MAX];
+--- a/src/webserver.c
++++ b/src/webserver.c
+@@ -1029,14 +1029,14 @@ int ws_returnerror(WS_CONNINFO *pwsc,int error, char *description) {
+ * and serves it up
+ */
+ void ws_defaulthandler(WS_PRIVATE *pwsp, WS_CONNINFO *pwsc) {
+- char path[MAXPATHLEN];
+- char resolved_path[MAXPATHLEN];
++ char path[PATH_MAX];
++ char resolved_path[PATH_MAX];
+ int file_fd;
+ off_t len;
+
+ DPRINTF(E_SPAM,L_WS,"Entering ws_defaulthandler\n");
+
+- snprintf(path,MAXPATHLEN,"%s/%s",pwsp->wsconfig.web_root,pwsc->uri);
++ snprintf(path,PATH_MAX,"%s/%s",pwsp->wsconfig.web_root,pwsc->uri);
+ if(!realpath(path,resolved_path)) {
+ pwsc->error=errno;
+ DPRINTF(E_WARN,L_WS,"Exiting ws_defaulthandler: Cannot resolve %s\n",path);
diff --git a/media-sound/mt-daapd/files/mt-daapd.tmpfiles b/media-sound/mt-daapd/files/mt-daapd.tmpfiles
new file mode 100644
index 000000000000..e0923ac06d7c
--- /dev/null
+++ b/media-sound/mt-daapd/files/mt-daapd.tmpfiles
@@ -0,0 +1 @@
+d /var/cache/mt-daapd 0755 root root -