summaryrefslogtreecommitdiff
path: root/media-sound/mpg123
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
commit61f62e5edc868fc4ae3b92af397397ee5056578a (patch)
tree81261ca75a34aa85973eeb3cd828878c4e72bcee /media-sound/mpg123
parent433cb2e828d414c74b16d429f40d25e179b0a70f (diff)
gentoo auto-resync : 16:01:2023 - 11:57:19
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/Manifest2
-rw-r--r--media-sound/mpg123/mpg123-1.31.2.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 8fd45b10bbc5..18dfe03ae73f 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,3 +1,5 @@
DIST mpg123-1.31.1.tar.bz2 1093324 BLAKE2B 47a845a5909874fe1e41a3a6b0ac57973f7bba69517b4ce6204a68f9f8c93b079062407fd6c1a9db42b8c7b483d3ba95a7257d1a8268b03f858f20d3695979de SHA512 d007ea94a99fde60919a173320e124c9f0079a28452533eeceb9c7bfed43810b46384ae45459ef6ac185e27ec06e153723bb588aaa4955ee2ad1c51dc58eb132
+DIST mpg123-1.31.2.tar.bz2 1093881 BLAKE2B a5c2d0a5df6067322979176498592a429c36fa06000b512e944b1f6ceeeae29fa3efeb0e5d604c8f2930aa51ae75e53be4312abaf74e43504fb1643b66b8b682 SHA512 eca285382ee3e780353834addf1336c4a2f8f11256af22f95e11efa243de669761c083c86ddfc6ac8c02a920a3c4ab4ad767efa2739fb052e9719f35ef407bc3
EBUILD mpg123-1.31.1.ebuild 3019 BLAKE2B d90a13f1c47e1375b151b43d6ea7c3487e96a2248bc4a5285c5e2aba166df4e64bd7881b5e24878dd3fe1dd6b32e307ae438131feb7ed3c1d9210941f21a932e SHA512 922ba2273f62408348138366e6936496463b9e78ebadf255d49bc7cd258997ec4c79d30ece9306a57defb50debdecddfd9ffa35e0399627a2df64c0b7eb401ae
+EBUILD mpg123-1.31.2.ebuild 3026 BLAKE2B e10f14a878fbfa768fd8d11c6117e36190e396bd05a4a0bdc713f62c7ffddc73fc19593f2c127be3ea06909875718b1dab6c2ebc2dae43937b9e16141e7f8ec5 SHA512 1373f98d03ce7660c3dcebd4da53511667977675219c23eb2f64f5c460d4df8beec34892329098012a57cfd6e4cb87b3a5afc343e1e43b2f3d45c1b2460c4ba6
MISC metadata.xml 526 BLAKE2B 42eed8f068420cefea4cf3e75a880889be7abe182feec2aa95e0e7f550cf68eb2582460e43500d24b7ad189adb3e0e135da1079efb405957fe3dfc6b93a91ece SHA512 11e572b6ec77d6c971766e666db84ee4b605479c3f89ba639177de7fb109a8d9e38d1f5034a52554736e6bd0915aae84830169ba3580f6d64794adc4c8cb9d0e
diff --git a/media-sound/mpg123/mpg123-1.31.2.ebuild b/media-sound/mpg123/mpg123-1.31.2.ebuild
new file mode 100644
index 000000000000..0d189895b3ef
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.31.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+# Note: build system prefers libsdl2 > libsdl. We could in theory add both
+# but it's tricky when it comes to handling switching between them properly.
+# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
+RDEPEND="
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-mpg123"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+
+ append-lfs-flags
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use cpu_flags_ppc_altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext
+ # bug #164504
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio="${_audio}"
+ --with-default-audio=${_output}
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}