summaryrefslogtreecommitdiff
path: root/media-sound/mpg123
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /media-sound/mpg123
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/Manifest2
-rw-r--r--media-sound/mpg123/mpg123-1.25.11.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 416f3e400b70..a4c74c827dea 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,3 +1,5 @@
DIST mpg123-1.25.10.tar.bz2 921219 BLAKE2B 04bfbe8915e3943ed42cc2d3597b0bd9c4686f77ee699f5845e7d1e905022206724cf23d6b0420a36e64b232f840dd9367f46f3c00dc2fe6256f44e8b83fa5b2 SHA512 a33666ae4aca7e7c1a93a6414d8c525ec19044c54f712d578180147d88e63033f7af2370b9ad22960cc3a0b454f15967b7a831cccc97e034c8855f70cdf1ab09
+DIST mpg123-1.25.11.tar.bz2 909478 BLAKE2B e821826c91acd3c0b4b9e6b83df6c5625f86611ecfdedd2dcc12b0ce8b3389199aa4cf7eea48b597e5b7f740bbe2c7612d27e75897e34bed2a2407e98b2b7a43 SHA512 986338d0f4829ec9e40990cb384746c7abfa80d3b3d5656b6dda73d03e2441c1f28ffbe7f3f82b0008a1c4ebcfa07aeffb493e95f13f7d04cbc818a09f1008ed
EBUILD mpg123-1.25.10-r1.ebuild 2860 BLAKE2B 0d25dbccc63c6788dd6c1e0c3a15fc8766d5e5616decfbcaa8f3567a53b98c01c6fcbbf23a4aab85369b14d8eb30498be411cf3cc1a8d577bf2f73dbc08849cd SHA512 20f23de51561b06b5dc1c6ef2923afb7f855caa234033847259223d8076588197f7c9f84be7421bf70d01f2cef3bacfa6b21cdb05e36c59539e06f9d3918bd44
+EBUILD mpg123-1.25.11.ebuild 2884 BLAKE2B c3d89fc5a388dedd602be32569f3d1269d1b30b1ca4728abb5e14b979a37ae1a29c11e76b0afdb5fd231419750d6707e6b2844485e867479f9c7f3a244d64898 SHA512 95c204f1ea1e0ff2406daef4114d21cdd74d62842215f977abdec3736c6e626345e112aaa8d035d67aec0306cb121f25f5c3b02c834c874e1965883d50fd3f1b
MISC metadata.xml 525 BLAKE2B 8604e161c32fb1f812a3f90d0489983289dc1db8ffc3dd259ea2cc2d8bbbf14a99448619f881c88f25188434efc903d399498126aceba9aa14e21094aa23dfa7 SHA512 06621f91056d0eb4131385dd430c15839c943d6560c59b711508064a8141020b795d0f7193f884365092332c4b3464dd0cd493e921519c9eab8b7ea4d9ce03b7
diff --git a/media-sound/mpg123/mpg123-1.25.11.ebuild b/media-sound/mpg123/mpg123-1.25.11.ebuild
new file mode 100644
index 000000000000..b0eac0164fa8
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.25.11.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+RDEPEND="
+ app-eselect/eselect-mpg123
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+pkg_setup() {
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+}
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
+ _cpu=generic_fpu
+ elif use x86-macos ; then
+ # ASM doesn't work quite as expected with the Darwin linker
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio="${_audio}"
+ --with-default-audio=${_output}
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}