summaryrefslogtreecommitdiff
path: root/media-sound/mpg123-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
commit8fd9d385e5bc3c01115ec2ddcb2227607eb90861 (patch)
treeaba1e6ef6b95e94172c009394cd1fcbc383e7d6e /media-sound/mpg123-base
parent1ddcee0bd115d2f843f82061cb0d1741bf90151d (diff)
gentoo auto-resync : 05:01:2024 - 14:04:25
Diffstat (limited to 'media-sound/mpg123-base')
-rw-r--r--media-sound/mpg123-base/Manifest3
-rw-r--r--media-sound/mpg123-base/metadata.xml18
-rw-r--r--media-sound/mpg123-base/mpg123-base-1.32.3.ebuild112
3 files changed, 133 insertions, 0 deletions
diff --git a/media-sound/mpg123-base/Manifest b/media-sound/mpg123-base/Manifest
new file mode 100644
index 000000000000..810b95cc0e9d
--- /dev/null
+++ b/media-sound/mpg123-base/Manifest
@@ -0,0 +1,3 @@
+DIST mpg123-1.32.3.tar.bz2 1111054 BLAKE2B 67f889403c2bb639d675ec5ebea5a19c4b7174971d62bdd8d940ad659e6b0c06dada38422fc9d71b878917aa89e305ec48c8faa78d65d507cd6a0c9a79951359 SHA512 946c1073b6eebfd65333ec543df1caeea25864479e9c8e153fb53d8b636cc756d8d81947f7b5cbedbbfb1ea664d3fb27562ed36e7726d95e80591bd2ad622afc
+EBUILD mpg123-base-1.32.3.ebuild 2943 BLAKE2B 13a1cc67514adbf35ce73d4b7f1256730875d3d8609040272f5733af759bafe6b363e7794e925c846d90af245b684806f4fcca14e9640c26df8b249cf5c4bb48 SHA512 40db4e77abbabc62df879b647b0302ae78e98eca3d327d2856d801a052662ce77f0ae5e48f3a3f7e501db9bfe6d21b15fec00b77a87cc0285ed5a23c84157030
+MISC metadata.xml 579 BLAKE2B e61622166d7240119fcdb5f79d5b228b5fef1086e818a3c5dce16d70f290b621a8c48efff36ff93d60cb63014e4d33db8401a902cdcc26d2779464788e735cb5 SHA512 f546df9ffe7d486a0f9450f86d531a48227820c597cb60216c61f589478fb312c1c1026deb90929feeb4b6804443ead310dbf1fdc3d1739a13220155c5523707
diff --git a/media-sound/mpg123-base/metadata.xml b/media-sound/mpg123-base/metadata.xml
new file mode 100644
index 000000000000..d86d05aa1cec
--- /dev/null
+++ b/media-sound/mpg123-base/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>thomas-forum@orgis.org</email>
+ <name>Thomas Orgis</name>
+ </maintainer>
+ <remote-id type="sourceforge">mpg123</remote-id>
+ </upstream>
+ <use>
+ <flag name="int-quality">Use rounding instead of fast truncation for integer output, where possible</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/mpg123-base/mpg123-base-1.32.3.ebuild b/media-sound/mpg123-base/mpg123-base-1.32.3.ebuild
new file mode 100644
index 000000000000..5b38b5b112cf
--- /dev/null
+++ b/media-sound/mpg123-base/mpg123-base-1.32.3.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="mpg123"
+MY_P="${MY_PN}-${PV}"
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+# Note: build system prefers libsdl2 > libsdl. We could in theory add both
+# but it's tricky when it comes to handling switching between them properly.
+# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
+RDEPEND="
+ !<media-sound/mpg123-1.32.3-r100
+ !media-libs/libmpg123
+ dev-libs/libltdl:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-mpg123"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+
+ # Rerun autotools with patched configure.ac
+ #eautoreconf
+}
+
+multilib_src_configure() {
+ local _audio=
+ local _cpu=generic_fpu
+
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+
+ append-lfs-flags
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in coreaudio pulseaudio jack alsa oss sdl portaudio nas ; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ fi
+ done
+ fi
+
+ use cpu_flags_ppc_altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext
+ # bug #164504
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio=dummy
+ --with-default-audio="${_audio} dummy"
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123} || die
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}