summaryrefslogtreecommitdiff
path: root/media-sound/mp3asm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /media-sound/mp3asm
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'media-sound/mp3asm')
-rw-r--r--media-sound/mp3asm/Manifest3
-rw-r--r--media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch11
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild18
3 files changed, 24 insertions, 8 deletions
diff --git a/media-sound/mp3asm/Manifest b/media-sound/mp3asm/Manifest
index 649adbfd8213..baa49190441a 100644
--- a/media-sound/mp3asm/Manifest
+++ b/media-sound/mp3asm/Manifest
@@ -1,3 +1,4 @@
+AUX mp3asm-0.1.3-fix-autotools.patch 179 BLAKE2B 423f263f1305f23189861ace8c44f8f4c10df05b7949d9d0b0b93f7f380eb8f546bd5653af1cd9d289dbf477db823a75bee8cb5058de8b842cf70d3f90c8c60e SHA512 052cfe837ef8736e974f1991b175c2a7d52992ffc80e11daa474d533a72f64ea333a9f2d0cb808f87f6d298c42fdd27706e6ecd863af28826fd525cbe386338a
DIST mp3asm-0.1.3-1.tar.bz2 46530 BLAKE2B 031ce687662f107285e373ccb1702743cd340017dd8b49414576454f12338824d1e417625fa1f6228d5f1dff33879b91c88e88ce2c7ee8deb498d01d2d165b57 SHA512 c22fa3a041940fa7826d3f5ea18dd42807ca9c7d87a56c9ae10cd96606e53d17d8e6259be75a77d1101d6cda033e8b48e2dd2303e91fdca338af19ef3522fb83
-EBUILD mp3asm-0.1.3-r2.ebuild 587 BLAKE2B 554c318a3c70b8e2b80b1cc97edf7cc577fdc0f673b0a559226f09de0d9c9ee5eb0ccfc6dd06d78f4734929a6fe8b3447f1ba2ad735533670d75daa4090cf87d SHA512 bcd9130caf24e1b5d1159eddd8bc1da6ed750499ed2a931099845c69c28bbc3f3086994d53da24bb54e66c255058dbbb9cb4f6bcb0950929668696205f025d64
+EBUILD mp3asm-0.1.3-r2.ebuild 624 BLAKE2B 0f127a8a5774ca3824c17f0fa7cdac16c66de67626a16ed9f54ca69b52a6f7a8409343e709a7fb755a74962672ea482cc498375801fa06993a7a36a440960adf SHA512 3aa235b52897954da1b2b4ed03ebe0787585b5c5da9e919fd08e4897ad22132a2dc75b4f972a677bb2852d63a23c8891342dd548af90e33f9a0f8a68f4d220c3
MISC metadata.xml 329 BLAKE2B e711686a35811a7bb61cd0fabe8d85630e6f1e86e44a3c497604850813e80f1a6658bd392a8018330e9c19458b80e976063ce94b9aae18ef6361198f4ef1bd9b SHA512 abbfd0fe24ced7e49baded7270f11e905e466e0a0c859001bf09f0b3a1e6501e463a2547577c398d1eeb6b47c1bc91ab73c3c89308963f753d8795a8f58490a7
diff --git a/media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch b/media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch
new file mode 100644
index 000000000000..334050d441a9
--- /dev/null
+++ b/media-sound/mp3asm/files/mp3asm-0.1.3-fix-autotools.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -7,8 +7,6 @@
+ dnl Checks for programs.
+ AC_PROG_LN_S
+
+-CFLAGS="-g -O -Wall"
+-
+ dnl Checks for libraries.
+
+ dnl Checks for header files.
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
index 467241065e7c..a03af0ddc1db 100644
--- a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit autotools
-MY_PV="${PV}-1" # Patchlevel
+MY_PV="${PV}-1" # Patchlevel
DESCRIPTION="A command line tool to clean and edit mp3 files"
HOMEPAGE="https://sourceforge.net/projects/mp3asm/"
@@ -18,11 +18,15 @@ KEYWORDS="amd64 ppc sparc x86"
# the author uses weird numbering...
S="${WORKDIR}/${PN}-0.1"
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+PATCHES=( "${FILESDIR}"/${P}-fix-autotools.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
- dobin src/mp3asm
- dodoc Changelog README
+ default
+ dodoc Changelog
}