summaryrefslogtreecommitdiff
path: root/media-sound/marrie/marrie-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-sound/marrie/marrie-0.4.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-sound/marrie/marrie-0.4.ebuild')
-rw-r--r--media-sound/marrie/marrie-0.4.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/media-sound/marrie/marrie-0.4.ebuild b/media-sound/marrie/marrie-0.4.ebuild
index 5e26f9cf5c9b..a1e727f450c9 100644
--- a/media-sound/marrie/marrie-0.4.ebuild
+++ b/media-sound/marrie/marrie-0.4.ebuild
@@ -4,35 +4,26 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
-GIT_ECLASS=""
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
fi
-inherit distutils-r1 ${GIT_ECLASS}
-
DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
HOMEPAGE="https://github.com/rafaelmartins/marrie"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-
LICENSE="BSD"
SLOT="0"
-IUSE=""
RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
pkg_postinst() {
- distutils-r1_pkg_postinst
elog
elog "You'll need a media player and a file downloader."
elog "Recommended packages: net-misc/wget and media-video/mpv"