summaryrefslogtreecommitdiff
path: root/media-sound/madplay/madplay-0.15.2b-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /media-sound/madplay/madplay-0.15.2b-r2.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'media-sound/madplay/madplay-0.15.2b-r2.ebuild')
-rw-r--r--media-sound/madplay/madplay-0.15.2b-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/madplay/madplay-0.15.2b-r2.ebuild b/media-sound/madplay/madplay-0.15.2b-r2.ebuild
new file mode 100644
index 000000000000..e365a62bc206
--- /dev/null
+++ b/media-sound/madplay/madplay-0.15.2b-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="The MAD audio player"
+HOMEPAGE="http://www.underbit.com/products/mad/"
+SRC_URI="mirror://sourceforge/mad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="alsa nls"
+
+RDEPEND="
+ media-libs/libid3tag:=
+ media-libs/libmad
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-macos.patch
+ "${FILESDIR}"/${P}-fix-autoconf.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with alsa) \
+ --without-esd
+}