summaryrefslogtreecommitdiff
path: root/media-sound/madplay/madplay-0.15.2b-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-sound/madplay/madplay-0.15.2b-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-sound/madplay/madplay-0.15.2b-r1.ebuild')
-rw-r--r--media-sound/madplay/madplay-0.15.2b-r1.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/media-sound/madplay/madplay-0.15.2b-r1.ebuild b/media-sound/madplay/madplay-0.15.2b-r1.ebuild
index 7a464f05ec31..742c63d7d8a4 100644
--- a/media-sound/madplay/madplay-0.15.2b-r1.ebuild
+++ b/media-sound/madplay/madplay-0.15.2b-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools epatch epunt-cxx
+EAPI=7
+
+inherit autotools
DESCRIPTION="The MAD audio player"
HOMEPAGE="http://www.underbit.com/products/mad/"
@@ -13,18 +14,18 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="alsa debug nls"
-RDEPEND=">=media-libs/libid3tag-0.15.1b
- >=media-libs/libmad-0.15.1b
- alsa? ( media-libs/alsa-lib )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+RDEPEND="
+ media-libs/libid3tag:=
+ media-libs/libmad:=
+ alsa? ( media-libs/alsa-lib:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
-DOCS="CHANGES CREDITS README TODO"
+PATCHES=( "${FILESDIR}"/${PN}-macos.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-macos.patch
- eautoreconf #need new libtool for interix
- epunt_cxx #74499
+ default
+ eautoreconf
}
src_configure() {