summaryrefslogtreecommitdiff
path: root/media-sound/madplay/madplay-0.15.2b-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/madplay/madplay-0.15.2b-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/madplay/madplay-0.15.2b-r1.ebuild')
-rw-r--r--media-sound/madplay/madplay-0.15.2b-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/madplay/madplay-0.15.2b-r1.ebuild b/media-sound/madplay/madplay-0.15.2b-r1.ebuild
new file mode 100644
index 000000000000..7a464f05ec31
--- /dev/null
+++ b/media-sound/madplay/madplay-0.15.2b-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools epatch epunt-cxx
+
+DESCRIPTION="The MAD audio player"
+HOMEPAGE="http://www.underbit.com/products/mad/"
+SRC_URI="mirror://sourceforge/mad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="alsa debug nls"
+
+RDEPEND=">=media-libs/libid3tag-0.15.1b
+ >=media-libs/libmad-0.15.1b
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS="CHANGES CREDITS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-macos.patch
+ eautoreconf #need new libtool for interix
+ epunt_cxx #74499
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug debugging) \
+ $(use_with alsa) \
+ --without-esd
+}