summaryrefslogtreecommitdiff
path: root/media-sound/mac/mac-4.11.4.5.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /media-sound/mac/mac-4.11.4.5.7-r1.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'media-sound/mac/mac-4.11.4.5.7-r1.ebuild')
-rw-r--r--media-sound/mac/mac-4.11.4.5.7-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/mac/mac-4.11.4.5.7-r1.ebuild b/media-sound/mac/mac-4.11.4.5.7-r1.ebuild
new file mode 100644
index 000000000000..aa65b9a5e9ee
--- /dev/null
+++ b/media-sound/mac/mac-4.11.4.5.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_PN=monkeys-audio
+MY_PV=$(ver_cut 1-2)-u$(ver_cut 3)-b$(ver_cut 4)-s$(ver_cut 5)
+MY_P=${MY_PN}_${MY_PV}
+
+DESCRIPTION="Monkey's Audio Codecs"
+HOMEPAGE="http://etree.org/shnutils/shntool/ http://www.deb-multimedia.org/dists/testing/main/binary-amd64/package/monkeys-audio.php"
+SRC_URI="http://www.deb-multimedia.org/pool/main/m/monkeys-audio/${MY_P}.orig.tar.gz"
+
+LICENSE="mac"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+RDEPEND=""
+DEPEND="
+ sys-apps/sed
+ cpu_flags_x86_mmx? ( dev-lang/yasm )
+"
+
+S=${WORKDIR}/${MY_P/_/-}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-output.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+ "${FILESDIR}"/${P}-null.patch
+)
+
+DOCS=( AUTHORS ChangeLog NEWS TODO README src/History.txt src/Credits.txt ChangeLog.shntool )
+
+RESTRICT="mirror"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-O3::' configure || die
+}
+
+src_configure() {
+ append-cppflags -DSHNTOOL
+ use cpu_flags_x86_mmx && append-ldflags -Wl,-z,noexecstack
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx assembly)
+}
+
+src_install() {
+ default
+
+ insinto /usr/include/${PN}
+ doins src/MACLib/{BitArray,UnBitArrayBase,Prepare}.h #409435
+
+ find "${D}" -name '*.la' -delete || die
+}