summaryrefslogtreecommitdiff
path: root/media-sound/lyvi/lyvi-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/lyvi/lyvi-2.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/lyvi/lyvi-2.0.0.ebuild')
-rw-r--r--media-sound/lyvi/lyvi-2.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/lyvi/lyvi-2.0.0.ebuild b/media-sound/lyvi/lyvi-2.0.0.ebuild
new file mode 100644
index 000000000000..545d85dd45fd
--- /dev/null
+++ b/media-sound/lyvi/lyvi-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple command-line lyrics viewer"
+HOMEPAGE="http://ok100.github.io/lyvi/"
+SRC_URI="https://github.com/ok100/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+KEYWORDS="amd64"
+SLOT="0"
+IUSE="mpris"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/plyr[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ mpris? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove pip dependency
+ sed -e '/require/d' --in-place setup.py || die
+ distutils-r1_python_prepare_all
+}