summaryrefslogtreecommitdiff
path: root/media-sound/lollypop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /media-sound/lollypop
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest2
-rw-r--r--media-sound/lollypop/lollypop-1.0.7.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 0e5532322f39..ef61ddd67c23 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,5 +1,7 @@
DIST lollypop-0.9.612.tar.xz 452072 BLAKE2B 784a7df8baa0b87fb34b6ab8b506d5ce1c90e78e959c6dbd07809c2765e4528c67bf358efc0eaeb03542640290b9fe181f99b2cc19cef3a3fbbb6a9bfc07afdc SHA512 dd61d38f245e6a8ad8eb5fad35fb23aa4a31399c2d2f628266b19aa00f6b615de82a6af33f2f4ae40f768a3786fb991e5f48dbcb0d7ba075579c6779fd05a371
DIST lollypop-0.9.908.tar.xz 468260 BLAKE2B 126ba0cf76f733cf05d50fc2e23e926e1e380c4f1bd6e2c100a2b2d3c25df4e1cad8cc8382021f80050dd1be3c0cb879fab829abf02acbfc18b960e8a49598c3 SHA512 a066e9d0854869b0d0ee3b0fb84b40a9a768934d475cf7c8bb3f88537eb18027b719660d717766b6ba2fd5ba0a2a25ff7adbda0219e99811e928150b448e6d7f
+DIST lollypop-1.0.7.tar.xz 436000 BLAKE2B 8b41a3378e39b0cba59323bbd7946226bcce29f80c878833ac920f337c036fcaca9c81caca2e360972295c6446c67d79e201093f86cad0685f7365a332d0e116 SHA512 ce537e60e3f1c678fcbf26d1305a178a3f2299abd4f75bb3c3a2cf717295e14aa73a8f21fb88d0c1fc790a80a572dbce84d01a0fe3229879124f89f8a5fa8305
EBUILD lollypop-0.9.612.ebuild 1332 BLAKE2B 2e92e7d2f1f7ef4811a9b20c92f17178ad21964c5679236cb298e1a24e001a4b5e74620b8cd7fe861474d91ae5059fae5fdc4f9119ba476298e0787ae90a5582 SHA512 f4b33867027ca9ca2a219a18299a00daaa857d89cfa9aba63401442fab2c2c665bb2a6f05fb2eb45332347915a5608f37924013cfa7ebbc0c444bf910fd651b8
EBUILD lollypop-0.9.908.ebuild 1332 BLAKE2B eb958a4f6485cfd37f744e7ee443e1ea4223c97ba89273b70c0d6906421e02c3476d7726eccaaf8e7bd50cd6536228abdde8ffc7b8adfca18091fe4dd6ab12d3 SHA512 ee6d04c61ffeb0c4d499f254e181a3662d7b1ebd0af70ebe2df6497ec21e5c4b3ea14759dce0e79d44c0d62d3552d2ffca47f52f3a1e8f0e5b86cc6fc361c3d1
+EBUILD lollypop-1.0.7.ebuild 1367 BLAKE2B 58e95f8666ace9c74cdba8e8ef4508b3ec8aadd40c5f07bbe1deb713f7da0f200827a66b23b28f73abbf130356cfced8e1309996ba793196e35c4d2ac233bf50 SHA512 8ddf6d570858bbdb8381ac75a419b2b6534d5c9165df166356783c7c02fe0ec6fca1cf79087a954680f17825d35ebfeae8e1ccf147ca701559e2415249825f32
MISC metadata.xml 245 BLAKE2B 26bf988c73d073000ab8d21ea881c4088b90e7081410938828744375bfa8de31cce2c78154ccfc61105c853c1f24f4994ca4e5cbb80c4c89dfd489bbd10a09ee SHA512 ecb8a4621081ccdd43f08e4f560b0bc820c27d6a282c87e1a8f77137ec8b215188fe31f11fc6379533afee2ebe7e14d5395a45c1aab9abfe423fd832dba692a4
diff --git a/media-sound/lollypop/lollypop-1.0.7.ebuild b/media-sound/lollypop/lollypop-1.0.7.ebuild
new file mode 100644
index 000000000000..80d94cea4023
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.0.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="04b4d9bdafd176f98dbd233c564bafb8"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}