summaryrefslogtreecommitdiff
path: root/media-sound/lollypop/lollypop-1.4.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
commit7051f2e58b6bbc371b2c94cead2715bf06310adb (patch)
treed8eb7cbcdfa3883fcdb1cb004774e17be52600b0 /media-sound/lollypop/lollypop-1.4.35.ebuild
parent3b4acc0bc0b77136b371d8a3119066f80f221efe (diff)
gentoo auto-resync : 11:01:2023 - 23:45:17
Diffstat (limited to 'media-sound/lollypop/lollypop-1.4.35.ebuild')
-rw-r--r--media-sound/lollypop/lollypop-1.4.35.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/lollypop/lollypop-1.4.35.ebuild b/media-sound/lollypop/lollypop-1.4.35.ebuild
new file mode 100644
index 000000000000..e8b553c2953e
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.35.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# Dependencies being checked by Meson
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/gtk+:3[introspection]
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-plugins/gst-plugins-pulse
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser[introspection]
+ gui-libs/libhandy:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ elog "Remember to install the necessary gst-plugins packages to read your audio files"
+ elog "You can also use the gst-plugins-meta pakcage and its USE flags."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}