summaryrefslogtreecommitdiff
path: root/media-sound/litestream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /media-sound/litestream
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'media-sound/litestream')
-rw-r--r--media-sound/litestream/Manifest3
-rw-r--r--media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch43
-rw-r--r--media-sound/litestream/litestream-1.3_rc3.ebuild31
3 files changed, 56 insertions, 21 deletions
diff --git a/media-sound/litestream/Manifest b/media-sound/litestream/Manifest
index 3501cae2ce59..d51ef279a9d2 100644
--- a/media-sound/litestream/Manifest
+++ b/media-sound/litestream/Manifest
@@ -1,3 +1,4 @@
+AUX litestream-1.3_rc3-fix-build-system.patch 1585 BLAKE2B 06dddd1f0e7815f539242de4842ca5e1cd2082a4ffd0943d81af38ba25e95de59de6319ebbb58f2cbac058dadd2b4369feff45517a9bf1995eece9982b9075b7 SHA512 7836b0af8305fba2ff201b9cb17da713b9a4d9963f7c7eb739fd9738b58f51da571f2b26029f977ce6336ecf1c0838576d5a6368d80c18d786a562352ac2e6dd
DIST litestream-1.3RC3.tar.gz 25018 BLAKE2B cf5b6b57dc1a466c21745372111f2d63be2029016308ec0d30d1c54ae30389df08ac6ac429b60b112adb85449da253567cd0228afa71fa0c56352035238bd5a4 SHA512 65cf43e852a35fc299d6b0e387ca67e6fc53694e8e63cd7f901544457887785780728ef064aed5f6b5bfbba09867f8a62e5d94a44d920ca44e0dbba663732c12
-EBUILD litestream-1.3_rc3.ebuild 953 BLAKE2B 4ec4ccb712280d171fb1941eb830b93707ad7b1d51ab7575956a58496542d0b3711aac3bf1f40f1b3f0c8538b36ab99c222f0d8fb17f1c0023f94706ae627277 SHA512 937a6ffa9091547597e86293eb0bf50c269b4818fbcd5434760ea6866d81482db354d4c4acd5124a1ca8ef8add07ba228fae6590045bdcfded05a63d96f99877
+EBUILD litestream-1.3_rc3.ebuild 723 BLAKE2B d6ae0b7052381367a88ed244af169dd2f815863deae775bcd565181dc6be192f546000963a6cd1a9f5a03a6dbfe99cf3a5b0af5ee20a64008a41c27a7ada6c23 SHA512 8a2f46ac29b46273497fae7af81af5309ee73cc1a3fe7adf3a1c0fa44ad1cdc7c65050bdd3cfad781893f168c0b7d8952f8b725882cf149db1cbb9befacbefdc
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch b/media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch
new file mode 100644
index 000000000000..0ef4eaa8a664
--- /dev/null
+++ b/media-sound/litestream/files/litestream-1.3_rc3-fix-build-system.patch
@@ -0,0 +1,43 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,32 +1,27 @@
+ # $Id: Makefile,v 1.8 2005/09/06 21:26:02 roundeye Exp $
+
+ INCLUDES = -Iinclude
+-AR= ar
+-RANLIB= sh ranlib.sh
+
+-CFLAGS = $(INCLUDES) -Wall -g -DVERSION="\"Litestream 1.2\""
++CFLAGS += -Wall
+
+-LDFLAGS = # -lnsl -lsocket
++CPPFLAGS += $(INCLUDES) -DVERSION="\"Litestream 1.2\"" -DNO_VARARGS
+
+ all: litestream literestream source client server
+
+ .depend: $(WILDCARD *.c)
+- $(CC) -MM $(CFLAGS) -DDEPEND *.c > .depend
++ $(CC) -MM $(CFLAGS) $(CPPFLAGS) -DDEPEND *.c > .depend
+
+-client: stream_cli.o stream_sched.o hexdump.o client.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++client: stream_cli.o stream_sched.o hexdump.o stream_log.o
+
+-server: stream_serv.o stream_sched.o hexdump.o server.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++server: stream_serv.o stream_sched.o hexdump.o stream_log.o
+
+ literestream: stream_serv.o stream_sched.o restream.o hexdump.o icy.o yp.o stream_cli.o http.o textutils.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+ litestream: stream_serv.o stream_sched.o stream.o hexdump.o icy.o yp.o stream_cli.o http.o textutils.o stream_log.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $^
+
+-source: stream_sched.o stream_cli.o http.o stream_log.o source.o mp3.o playlist.o textutils.o
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++source: stream_sched.o stream_cli.o http.o stream_log.o mp3.o playlist.o textutils.o
+
+ clean:
+ rm -f *.o source server client litestream literestream .depend *.core
diff --git a/media-sound/litestream/litestream-1.3_rc3.ebuild b/media-sound/litestream/litestream-1.3_rc3.ebuild
index 21c193593598..e0d4d98fac8d 100644
--- a/media-sound/litestream/litestream-1.3_rc3.ebuild
+++ b/media-sound/litestream/litestream-1.3_rc3.ebuild
@@ -1,40 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_P=${P/_rc/RC}
+inherit toolchain-funcs
DESCRIPTION="Litstream is a lightweight and robust shoutcast-compatible streaming mp3 server"
HOMEPAGE="http://www.litestream.org/"
-SRC_URI="http://litestream.org/litestream/${MY_P}.tar.gz"
+SRC_URI="http://litestream.org/litestream/${P/_rc/RC}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc sparc x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e 's:CFLAGS = :CFLAGS = ${OPTFLAGS} :; s:-g::' \
- Makefile || die "sed failed"
-}
+S="${WORKDIR}/${P/_rc/RC}"
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
-src_compile() {
- append-flags "-DNO_VARARGS"
- emake CC=$(tc-getCC) OPTFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin litestream literestream || die "dobin failed"
+ dobin litestream literestream
newbin source litestream-source
newbin server litestream-server
newbin client litestream-client
- dodoc ABOUT ACKNOWLEDGEMENTS BUGS CHANGELOG CONTACT FILES MAKEITGO README
+ einstalldocs
+ dodoc ABOUT ACKNOWLEDGEMENTS CONTACT FILES MAKEITGO
}