summaryrefslogtreecommitdiff
path: root/media-sound/linux-show-player
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 19:01:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 19:01:08 +0000
commitfc68863e718441fe15bb0dea2ca03ea06a6f558d (patch)
tree5cfeda3e589273a4fa9d6c84119acf0db4c2453c /media-sound/linux-show-player
parentecf595717796995cab38a07093dc9597d55d0ea6 (diff)
gentoo auto-resync : 25:03:2024 - 19:01:08
Diffstat (limited to 'media-sound/linux-show-player')
-rw-r--r--media-sound/linux-show-player/Manifest2
-rw-r--r--media-sound/linux-show-player/linux-show-player-0.6.1.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/linux-show-player/Manifest b/media-sound/linux-show-player/Manifest
index 672c20a33228..6b59ce10ac21 100644
--- a/media-sound/linux-show-player/Manifest
+++ b/media-sound/linux-show-player/Manifest
@@ -1,3 +1,5 @@
DIST linux-show-player-0.5.3.tar.gz 1080409 BLAKE2B 8292263965434587b0086c6505167a1a3dbe82593a07a7c26855136f8c330ffd1c16ecd1e7e758af7e07731df7db79a66743297d22594d9332025e73a7990c34 SHA512 f60f65c045fb57c2c2e5f2daf6b225115a0f4fef173869e971741f2e40b71931b88e56c2343c348701784449d1f032219d307cdb7bb31d6283ea2b0c816d0286
+DIST linux-show-player-0.6.1.tar.gz 1955112 BLAKE2B c655aac4f83653c96b728ca8d0a249343697fb98ba1fb885220d300ab08d71c564f06a355d67c9d920654a3c7388876ef57eaa4538fe5a70b0395e590a061961 SHA512 7bab76b3f9bf354479a57d0bc4492c6f47e93a05692b878aa8ee6aa025cdb97f2c2a84b88c70fc1d88f5742b614a5d283afa6397c57612bcd6b0828b67a71042
EBUILD linux-show-player-0.5.3-r1.ebuild 1412 BLAKE2B 5cfa9387fc4764e3aa10c12d38833730ed3038d24888f62706ecf315970efc0620b0717b0d6f199b683333adfd2bc39303eca95fc6714333f7c1bd7e18b4a22b SHA512 e6bc7cad3b71c0e389783019617b7d1ba21e95992ab5d6b14a9ec1b73e7f63601402dc306633600966840c6e0d811129f89d78c1c523878e4255af712b51e663
+EBUILD linux-show-player-0.6.1.ebuild 2250 BLAKE2B 9b548a925201ffe7a116fed74b0eca18b00785dfca0504f79a159c123e6b136e360c628a22e2ba678fc327c0b09b9082ba439744d0c92a057697d088644dbf02 SHA512 7e419c5003d90e2fc5f5e91898a0886d9e6b7d6cf51ed51e65adf96cbc109ec6463b68cd2b33b08b0b3807fa23e190c637361bead2b4fe2bffdb00628d0e501d
MISC metadata.xml 638 BLAKE2B 30c169a359156e6bcb409a916e4ce3b945de3cc98c5701ff542a4fa8c9f2bebda6c429e0fb9325dbdad0cb5d6684a6387e7a608bb69489e4188448a3466d2df9 SHA512 34695cea0fe0e137c25fef3998d01f200feadb38966a67c2ae6d8ee41a4c697f4e581c6133487e23e4ee20de072b06167389361f79417f5d5e207063f4d49247
diff --git a/media-sound/linux-show-player/linux-show-player-0.6.1.ebuild b/media-sound/linux-show-player/linux-show-player-0.6.1.ebuild
new file mode 100644
index 000000000000..a70843e858f4
--- /dev/null
+++ b/media-sound/linux-show-player/linux-show-player-0.6.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by pyalsa: https://github.com/alsa-project/alsa-python/issues/8
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="A cue player designed for stage productions"
+HOMEPAGE="https://www.linux-show-player.org/ https://github.com/FrancescoCeruti/linux-show-player/"
+SRC_URI="https://github.com/FrancescoCeruti/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa jack midi pulseaudio timecode"
+
+# TODO:
+# - network mode - falcon not packaged (QA issues, several unpackaged test dependencies)
+# - Open Sound Control support - pyliblo3 not packaged (last release in 2021, fails to build against modern cython)
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+ ')
+ media-libs/gstreamer[introspection]
+ alsa? (
+ $(python_gen_cond_dep '
+ dev-python/pyalsa[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base[alsa]
+ )
+ jack? (
+ $(python_gen_cond_dep '
+ dev-python/jack-client[${PYTHON_USEDEP}]
+ ')
+ media-plugins/gst-plugins-jack
+ )
+ midi? (
+ $(python_gen_cond_dep '
+ dev-python/mido[rtmidi,${PYTHON_USEDEP}]
+ ')
+ )
+ pulseaudio? ( media-plugins/gst-plugins-pulse )
+ timecode? (
+ app-misc/ola[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "${PN} uses GStreamer as its audio back-end so make sure you have plug-ins installed for all the audio formats you want to use"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 0.6.0; then
+ ewarn "Please be warned that current versions of ${PN} *cannot* open 0.5.x save files."
+ ewarn "Unfortunately upstream has provided no workaround for this."
+ ewarn
+ break
+ fi
+ done
+ fi
+
+ if use timecode; then
+ elog "Remember to start an OLA session on your computer if you want ${PN} to send timecodes"
+ fi
+}