summaryrefslogtreecommitdiff
path: root/media-sound/lash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-sound/lash
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-sound/lash')
-rw-r--r--media-sound/lash/Manifest1
-rw-r--r--media-sound/lash/lash-0.5.4-r5.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/media-sound/lash/Manifest b/media-sound/lash/Manifest
index 28048b4ab6d5..0f4d25e6dd49 100644
--- a/media-sound/lash/Manifest
+++ b/media-sound/lash/Manifest
@@ -5,4 +5,5 @@ AUX lash-0.5.4-swig_version_comparison.patch 1225 BLAKE2B 92f9fe4ae053dc454f8434
AUX lash-0.5.4-underlinking.patch 660 BLAKE2B 6f3ca7580a588493610869ae8f2ff58f1c53b8e593e45c8613b1a15e7b97521f01372b493d3f627d878a8f0f6a349460da6fcc1eb48cb2b7e18e283acdc3a81b SHA512 118bccb0da55f0e7808424696143b00784afb18cdf982fdef837bdafa1dea6b55ed912762a964e210c2f0ba4a3bd1469249cad957428cca87da6bd0514751d66
DIST lash-0.5.4.tar.gz 623469 BLAKE2B 463931a9fcacf806631746c69ccb2e2b795b8983e796835abce6036ed98571c41253fb8236a33c0a8bd1b5d3a910229d4e95f99257c1d82c64495201c64c6414 SHA512 93193dd585738b8c3432b3f75864d287f874b5618100a84f0a1b2bda2df15403203cfc66e7a0298adab7ef95bfdded81697614ca5ef8eaf5cebdde5860f47e3c
EBUILD lash-0.5.4-r4.ebuild 2587 BLAKE2B c88135133e9c6401c309e936611b909c901e912485d1af5b946ff2af54f1e8c2911936dc927a0a96889f213a79033bc502e1d1c016961490672e21aa6f37b738 SHA512 74f9459771d9275fccc8f883d141e9c72bc5a652db3713ca89651748ab59cd8410d13eaafe59d8e7ddc67b855383c7f92adc8e0bb012ed3fd8986e5347f46c3f
+EBUILD lash-0.5.4-r5.ebuild 2587 BLAKE2B e339534113e547c462a196e756be87ee4ddab21fbab94795cf792958d5453cff1671854c24785f475d0551ba3b6c66e42f25cfaecc7d26faf1d737fda43c26c3 SHA512 9dfbbb4eceeb95289bd756755399fed1bc93a08388256f2321dc301dd2787064e85bddf1f48758d7d43ef32ab6a5275f5d2da9aa2e5fa7ccc23d34d4397a7fdf
MISC metadata.xml 256 BLAKE2B 211ca90d8f704be5ca8a1994f0e8f1adbe1fd4937a10a301ced0b9be171dfdabb223661d168535cd7f5edfe0c8edca4620945e13dc3c43b5832ac183913188f0 SHA512 fde3b658512fa6742886d7dd84efc906331b43f5b0f8fdca353fe2280653381716d7143473c9237b9fe58b9df5889b38b008da34f6ce4b64336f38642d78e3dd
diff --git a/media-sound/lash/lash-0.5.4-r5.ebuild b/media-sound/lash/lash-0.5.4-r5.ebuild
new file mode 100644
index 000000000000..8a2d81ff5459
--- /dev/null
+++ b/media-sound/lash/lash-0.5.4-r5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..11} )
+
+inherit autotools multilib-minimal python-single-r1
+
+DESCRIPTION="LASH Audio Session Handler"
+HOMEPAGE="http://www.nongnu.org/lash/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
+IUSE="alsa debug gtk python static-libs" # doc
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/libxml2
+ sys-apps/util-linux[${MULTILIB_USEDEP}]
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ gtk? ( x11-libs/gtk+:2 )
+ python? ( ${PYTHON_DEPS} )
+ || ( sys-libs/readline dev-libs/libedit )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+"
+# doc? ( >=app-text/texi2html-5 )
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+HTML_DOCS=( docs/lash-manual-html-one-page/lash-manual.html )
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc2.8.patch
+ "${FILESDIR}"/${P}-swig_version_comparison.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-strcmp.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e '/texi2html/s:-number:&-sections:' \
+ docs/Makefile.am || die #422045
+
+ default
+
+ AT_M4DIR=m4 eautoreconf
+}
+
+multilib_src_configure() {
+ # 'no' could be '$(usex doc)' but we use the pregenerated lash-manual.html
+ export ac_cv_prog_lash_texi2html=no #422045
+
+ # --enable-pylash would disable it
+ local myconf=()
+ if ! multilib_is_native_abi || ! use python; then
+ myconf+=( --disable-pylash )
+ fi
+
+ if ! multilib_is_native_abi; then
+ # disable remaining configure checks
+ myconf+=(
+ JACK_CFLAGS=' '
+ JACK_LIBS=' '
+ XML2_CFLAGS=' '
+ XML2_LIBS=' '
+
+ vl_cv_lib_readline=no
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable alsa alsa-midi) \
+ $(multilib_native_use_enable gtk gtk2) \
+ $(multilib_native_use_enable debug) \
+ "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -C liblash
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+ else
+ # headers
+ emake -C lash DESTDIR="${D}" install
+ # library
+ emake -C liblash DESTDIR="${D}" install
+ # pkg-config
+ emake DESTDIR="${D}" install-pkgconfigDATA
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+ use python && python_optimize
+}