summaryrefslogtreecommitdiff
path: root/media-sound/k4guitune/k4guitune-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/k4guitune/k4guitune-1.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/k4guitune/k4guitune-1.1.1.ebuild')
-rw-r--r--media-sound/k4guitune/k4guitune-1.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/k4guitune/k4guitune-1.1.1.ebuild b/media-sound/k4guitune/k4guitune-1.1.1.ebuild
new file mode 100644
index 000000000000..e6af74cbea54
--- /dev/null
+++ b/media-sound/k4guitune/k4guitune-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+QT3SUPPORT_REQUIRED="true"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Program to tune musical instruments using your computer's mic- or line- input"
+HOMEPAGE="http://wspinell.altervista.org/k4guitune/ http://www.kde-apps.org/content/show.php/K4Guitune?content=117669"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/117669-${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sci-libs/fftw:3.0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}/${P}-desktop_entry.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_doc=$(usex handbook)
+ )
+
+ kde4-base_src_configure
+}