summaryrefslogtreecommitdiff
path: root/media-sound/jackbeat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/jackbeat/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/jackbeat/files')
-rw-r--r--media-sound/jackbeat/files/jackbeat-0.7.6-automagic-pulse.patch36
-rw-r--r--media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch17
2 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/jackbeat/files/jackbeat-0.7.6-automagic-pulse.patch b/media-sound/jackbeat/files/jackbeat-0.7.6-automagic-pulse.patch
new file mode 100644
index 000000000000..5f1aca5d3a32
--- /dev/null
+++ b/media-sound/jackbeat/files/jackbeat-0.7.6-automagic-pulse.patch
@@ -0,0 +1,36 @@
+--- jackbeat-0.7.6/configure.ac.orig
++++ jackbeat-0.7.6/configure.ac
+@@ -67,20 +67,25 @@
+ AC_SUBST(JACK_LIBS)
+ AM_CONDITIONAL(HAVE_JACK, [test "$have_jack" = "1"])
+
+-PKG_CHECK_MODULES(PULSE, libpulse-simple >= 0.9.10, [have_pulse=1], true)
+-AC_SUBST(PULSE_CFLAGS)
+-AC_SUBST(PULSE_LIBS)
+-if test "$have_pulse" = "1"
++AC_ARG_WITH([pulse], [AS_HELP_STRING([--without-pulse], [disable PulseAudio support])], [], [with_pulse=yes])
++
++if test "x$with_pulse" != xno
+ then
+- AC_DEFINE(HAVE_PULSE, [1], [PulseAudio support])
++ PKG_CHECK_MODULES(PULSE, libpulse-simple >= 0.9.10, [have_pulse=1], true)
++else
++ AC_MSG_CHECKING([for PULSE])
++ AC_MSG_RESULT([disabled])
+ fi
+-AM_CONDITIONAL(HAVE_PULSE, [test "$have_pulse" = "1"])
+
+-if test "$have_pulse" = "" && test "$is_linux" = "1"
++if test "$have_pulse" != ""
+ then
+- AC_MSG_WARN([Can't find libpulse, PulseAudio will not be supported])
++ AC_DEFINE(HAVE_PULSE, [1], [PulseAudio support])
+ fi
+
++AC_SUBST(PULSE_CFLAGS)
++AC_SUBST(PULSE_LIBS)
++AM_CONDITIONAL(HAVE_PULSE, [test "$have_pulse" = "1"])
++
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.12, [have_pkg_gtk=true], true)
+
+ if test x$have_pkg_gtk = xtrue
diff --git a/media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch b/media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch
new file mode 100644
index 000000000000..878929c36693
--- /dev/null
+++ b/media-sound/jackbeat/files/jackbeat-0.7.6-underlinking.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/508988
+
+jackbeat-builder.o:builder.c:function gui_builder_connect_func: error: undefined reference to 'g_module_symbol'
+jackbeat-builder.o:builder.c:function gui_builder_connect_func: error: undefined reference to 'g_module_supported'
+jackbeat-builder.o:builder.c:function gui_builder_connect_func: error: undefined reference to 'g_module_open'
+
+--- configure.ac
++++ configure.ac
+@@ -86,7 +86,7 @@
+ AC_SUBST(PULSE_LIBS)
+ AM_CONDITIONAL(HAVE_PULSE, [test "$have_pulse" = "1"])
+
+-PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.12, [have_pkg_gtk=true], true)
++PKG_CHECK_MODULES(GTK, gmodule-2.0 gtk+-2.0 >= 2.12, [have_pkg_gtk=true], true)
+
+ if test x$have_pkg_gtk = xtrue
+ then