summaryrefslogtreecommitdiff
path: root/media-sound/jack/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/jack/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/jack/files')
-rw-r--r--media-sound/jack/files/jack-3.1.1-add-cddbserver-musicbrainz.patch15
-rw-r--r--media-sound/jack/files/jack-3.1.1-python26.patch12
-rw-r--r--media-sound/jack/files/jack-3.1.1-setup-and-cursesmodule.patch47
3 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/jack/files/jack-3.1.1-add-cddbserver-musicbrainz.patch b/media-sound/jack/files/jack-3.1.1-add-cddbserver-musicbrainz.patch
new file mode 100644
index 000000000000..150c44090642
--- /dev/null
+++ b/media-sound/jack/files/jack-3.1.1-add-cddbserver-musicbrainz.patch
@@ -0,0 +1,15 @@
+--- a/jack_freedb.py
++++ b/jack_freedb.py
+@@ -46,6 +46,12 @@
+ 'mail': "freedb-submit@freedb.org",
+ 'my_mail': "default"
+ },
++ 'musicbrainz': {
++ 'host': "freedb.musicbrainz.org",
++ 'id': prog_name + " " + prog_version,
++ 'mail': "",
++ 'my_mail': "default"
++ },
+ }
+
+ def interpret_db_file(all_tracks, freedb_form_file, verb, dirs = 0, warn = None):
diff --git a/media-sound/jack/files/jack-3.1.1-python26.patch b/media-sound/jack/files/jack-3.1.1-python26.patch
new file mode 100644
index 000000000000..c3e0a0c9f856
--- /dev/null
+++ b/media-sound/jack/files/jack-3.1.1-python26.patch
@@ -0,0 +1,12 @@
+--- a/jack_functions.py
++++ b/jack_functions.py
+@@ -219,9 +219,9 @@
+ ff = blocks % CDDA_BLOCKS_PER_SECOND
+ return mm, ss, ff, blocks
+
+-def starts_with(str, with):
+- "checks whether str starts with with"
+- return str[0:len(with)] == with
++def starts_with(str, withstr):
++ "checks whether str starts with withstr"
++ return str[0:len(withstr)] == withstr
diff --git a/media-sound/jack/files/jack-3.1.1-setup-and-cursesmodule.patch b/media-sound/jack/files/jack-3.1.1-setup-and-cursesmodule.patch
new file mode 100644
index 000000000000..d3e016289a81
--- /dev/null
+++ b/media-sound/jack/files/jack-3.1.1-setup-and-cursesmodule.patch
@@ -0,0 +1,47 @@
+--- a/jack_t_curses.py
++++ b/jack_t_curses.py
+@@ -35,11 +35,9 @@
+ try:
+ from jack_curses import endwin, resizeterm, A_REVERSE, newwin, newpad, initscr, noecho, cbreak, echo, nocbreak
+ except ImportError:
+- warning("jack_curses module not found, trying normal curses...")
++ info("jack_curses module not found, using normal curses...")
+ try:
+- from curses import endwin, A_REVERSE, newwin, newpad, initscr, noecho, cbreak, echo, nocbreak
+- def resizeterm(y, x):
+- pass
++ from curses import endwin, resizeterm, A_REVERSE, newwin, newpad, initscr, noecho, cbreak, echo, nocbreak
+ except ImportError:
+ print "curses module not found or too old, please install it (see README)"
+
+--- a/setup.py
++++ b/setup.py
+@@ -2,7 +2,7 @@
+
+ """Setup script for the jack module distribution."""
+
+-from distutils.core import setup, Extension
++from distutils.core import setup
+
+ setup( # Distribution meta-data
+ name = "jack",
+@@ -11,11 +11,7 @@
+ author = "Arne Zellentin",
+ author_email = "zarne@users.sf.net",
+ url = "http://www.home.unix-ag.org/arne/jack/",
+-
+- # Description of the modules and packages in the distribution
+- ext_modules = [ Extension('jack_cursesmodule',
+- ['cursesmodule/jack_cursesmodule.c'], libraries=["ncurses"],
+- extra_compile_args=["-Wno-strict-prototypes"]) ],
++ scripts=['jack'],
+
+ py_modules = [ 'jack_CDTime', 'jack_TOC', 'jack_TOCentry', 'jack_argv',
+ 'jack_checkopts', 'jack_children', 'jack_config', 'jack_constants',
+@@ -26,6 +22,3 @@
+ 'jack_ripstuff', 'jack_status', 'jack_t_curses', 'jack_t_dumb', 'jack_tag',
+ 'jack_targets', 'jack_term', 'jack_utils', 'jack_version', 'jack_workers']
+ )
+-
+-print "If you have installed the modules, copy jack to some place in your $PATH,"
+-print "like /usr/local/bin/."