summaryrefslogtreecommitdiff
path: root/media-sound/guitarix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /media-sound/guitarix
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/Manifest4
-rw-r--r--media-sound/guitarix/guitarix-0.39.0.ebuild76
-rw-r--r--media-sound/guitarix/metadata.xml7
3 files changed, 83 insertions, 4 deletions
diff --git a/media-sound/guitarix/Manifest b/media-sound/guitarix/Manifest
index 55565b0038e9..7e4d98adbf1f 100644
--- a/media-sound/guitarix/Manifest
+++ b/media-sound/guitarix/Manifest
@@ -1,4 +1,6 @@
DIST guitarix2-0.38.1.tar.xz 80768608 BLAKE2B fd745955d8b44da72c669e69c36294d4a2131f2b5868e7e254a0b33768852ba9fcf9302f2a7ebd962c8a6dc02a543f70574466c51341a371c9fb988989123e50 SHA512 54d08b4ed20b9df4c69d0c86e4d668c53fffde8919f5570f376cee903926bd01945169d177d0d45976569ea55b28f8dca7884ac6dfe2f063df6583467559c5b7
+DIST guitarix2-0.39.0.tar.xz 80769472 BLAKE2B a699545b7e4a9992ed11a17ee9f82170c1891a95a0543c3b847ff2a02ab4e6597c28cbb4708f85022b1e94f0184b6dc712c271729bdda07373101ea9e8a1323f SHA512 5eb799498385ab9aa865e3f5a7e79d77f7f62c9bd7ad6875ec32bdec85829ed5b84bed3b0eab786ce74088fe2e1d53080f70afcb25ab1ef8d8f78a676b4947df
EBUILD guitarix-0.38.1-r1.ebuild 1713 BLAKE2B 3ad1114341e087c23c93c6e2254c5a421db7b70bb142d4d21c9785baedadabc8e1c107eafc7b8e762c6fb4e3364590b6f2ccf8d0ee62a39d01d8b0dd02e85be6 SHA512 c50aa18d3ee47b2c865415c259f925a7bf3d0a78737e779f2c9790ab62c099a40826cb82254456b00379486e45c5c20c7643d62bfe4b8c4962183c2421f523e9
+EBUILD guitarix-0.39.0.ebuild 1725 BLAKE2B bc8b07d52d1ca21cd2e0108ee760aa086ea389b2c01d06d404b9d264ad25e549c288a60a13aeab11474055937dbe37da1a2045b98bd287ebde7eeade1ee88470 SHA512 43f1d52c476823e3513aff1d5456b4dc97d7d048826f4d5cf1f538b61b6ae24b2b14a5ce9afc53e4575fbbfd59a13bb3eb93d167155be3fd66a26cb5459b0389
EBUILD guitarix-9999.ebuild 1739 BLAKE2B 852d66f82f19f896a39b2353a6421ac2de9b8ac4887554dd35c9f585ace40e11809d1fee8f6a1f9a2d1377bc1754c35be27875f7f58bc40a319dd2c9155fb3c6 SHA512 bd525153a675570d3d08922cb8434c8dedfdca76ba4be39296488d06ddabd90ac943b840c3544aef05181e4e5b2fe016cb2452393944afeee5261758fded390a
-MISC metadata.xml 622 BLAKE2B 390ed1150f373c73c5bbcd5e5193e8465ac348bebae4a5f8484fb214172717d5166c0a17be6afb4e5091c4318cd3a3e30bcc05c70fff78423347298acbc64c61 SHA512 b18db16b6af5381331418267660822972be42997065eed2182c6305ce84bd61fb6d3ee01de195f3f8f01570deed7f97b93ca31916986609a374c1f5962c45dce
+MISC metadata.xml 595 BLAKE2B 22b392d194412eb045a3892e77a79f809215cdfc7e7afa42da59284f88975bd6d789a5a8e215c1137093266ba19e0be463d7b51b7b6506ff38f8591fd7b5cefb SHA512 5ccc8bcc15cf8fd7a5a4e18cb805765d6cc1b735c08b3194f3b4bc20d94e4d00d1db4fb9869bd58c82bcd39951d7421647811f61f7add2733e6719e6b5d78c3d
diff --git a/media-sound/guitarix/guitarix-0.39.0.ebuild b/media-sound/guitarix/guitarix-0.39.0.ebuild
new file mode 100644
index 000000000000..275c99ec7948
--- /dev/null
+++ b/media-sound/guitarix/guitarix-0.39.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils xdg
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="http://guitarix.org/"
+SRC_URI="mirror://sourceforge/guitarix/guitarix/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bluetooth debug lv2 nls +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+COMMON_DEPEND="dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
+ >=media-libs/libsndfile-1.0.17
+ >=media-libs/zita-convolver-3:=
+ media-libs/zita-resampler
+ >=net-misc/curl-7.26.0
+ >=sci-libs/fftw-3.1.2:3.0=
+ x11-libs/gtk+:2
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# clearlooks gtk engine and roboto fonts are required for correct ui rendering
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gtk-engines
+ standalone? (
+ media-fonts/roboto
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+"
+
+DOCS=( changelog README )
+
+src_configure() {
+ local myconf=(
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex standalone "" "--no-standalone")
+ $(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
+}
diff --git a/media-sound/guitarix/metadata.xml b/media-sound/guitarix/metadata.xml
index 567aa7cf7675..73245221dba8 100644
--- a/media-sound/guitarix/metadata.xml
+++ b/media-sound/guitarix/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
+ <email>fordfrog@gentoo.org</email>
+ <name>Miroslav Ć ulc</name>
+ </maintainer>
+ <maintainer type="person">
<email>alexander@tsoy.me</email>
<name>Alexander Tsoy</name>
</maintainer>
@@ -9,9 +13,6 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
- <longdescription lang="en">
- guitarix is a virtual guitar amplifier for Linux running on Jack Audio Connection Kit
- </longdescription>
<use>
<flag name="lv2">Build lv2 plugins</flag>
<flag name="standalone">Build standalone application</flag>