summaryrefslogtreecommitdiff
path: root/media-sound/guitarix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-sound/guitarix
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/Manifest3
-rw-r--r--media-sound/guitarix/guitarix-0.38.1-r1.ebuild2
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild78
3 files changed, 81 insertions, 2 deletions
diff --git a/media-sound/guitarix/Manifest b/media-sound/guitarix/Manifest
index 6f4cea197eb9..55565b0038e9 100644
--- a/media-sound/guitarix/Manifest
+++ b/media-sound/guitarix/Manifest
@@ -1,3 +1,4 @@
DIST guitarix2-0.38.1.tar.xz 80768608 BLAKE2B fd745955d8b44da72c669e69c36294d4a2131f2b5868e7e254a0b33768852ba9fcf9302f2a7ebd962c8a6dc02a543f70574466c51341a371c9fb988989123e50 SHA512 54d08b4ed20b9df4c69d0c86e4d668c53fffde8919f5570f376cee903926bd01945169d177d0d45976569ea55b28f8dca7884ac6dfe2f063df6583467559c5b7
-EBUILD guitarix-0.38.1-r1.ebuild 1714 BLAKE2B d61e321fa0e1083f1a21a278f061f578188e7ac0a9d4486500c210e895cdc563031e1e9cc78a24da7e6aed81adf9fe9f3cf8ffc293fadaf623aba6d70e30c1a5 SHA512 d06d7eb88b3cfe10e1a5de7564a173de61abc3497480880828f028c27342430b596180dc2d5c31051a704d3fde282aa076a9df3f44dd73fcb6a8e9ea44ec8832
+EBUILD guitarix-0.38.1-r1.ebuild 1713 BLAKE2B 3ad1114341e087c23c93c6e2254c5a421db7b70bb142d4d21c9785baedadabc8e1c107eafc7b8e762c6fb4e3364590b6f2ccf8d0ee62a39d01d8b0dd02e85be6 SHA512 c50aa18d3ee47b2c865415c259f925a7bf3d0a78737e779f2c9790ab62c099a40826cb82254456b00379486e45c5c20c7643d62bfe4b8c4962183c2421f523e9
+EBUILD guitarix-9999.ebuild 1739 BLAKE2B 852d66f82f19f896a39b2353a6421ac2de9b8ac4887554dd35c9f585ace40e11809d1fee8f6a1f9a2d1377bc1754c35be27875f7f58bc40a319dd2c9155fb3c6 SHA512 bd525153a675570d3d08922cb8434c8dedfdca76ba4be39296488d06ddabd90ac943b840c3544aef05181e4e5b2fe016cb2452393944afeee5261758fded390a
MISC metadata.xml 622 BLAKE2B 390ed1150f373c73c5bbcd5e5193e8465ac348bebae4a5f8484fb214172717d5166c0a17be6afb4e5091c4318cd3a3e30bcc05c70fff78423347298acbc64c61 SHA512 b18db16b6af5381331418267660822972be42997065eed2182c6305ce84bd61fb6d3ee01de195f3f8f01570deed7f97b93ca31916986609a374c1f5962c45dce
diff --git a/media-sound/guitarix/guitarix-0.38.1-r1.ebuild b/media-sound/guitarix/guitarix-0.38.1-r1.ebuild
index b8e71bf7171b..86dcaacde860 100644
--- a/media-sound/guitarix/guitarix-0.38.1-r1.ebuild
+++ b/media-sound/guitarix/guitarix-0.38.1-r1.ebuild
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/guitarix/guitarix/${MY_P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="bluetooth debug lv2 nls +standalone zeroconf"
REQUIRED_USE="|| ( lv2 standalone )"
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
new file mode 100644
index 000000000000..a459bbec550b
--- /dev/null
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils xdg git-r3
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="http://guitarix.org/"
+EGIT_REPO_URI="https://git.code.sf.net/p/guitarix/git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="bluetooth debug lv2 nls +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+COMMON_DEPEND="dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/glib:2
+ >=media-libs/libsndfile-1.0.17
+ >=media-libs/zita-convolver-3:=
+ media-libs/zita-resampler
+ >=net-misc/curl-7.26.0
+ >=sci-libs/fftw-3.1.2:3.0=
+ x11-libs/gtk+:2
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# clearlooks gtk engine and roboto fonts are required for correct ui rendering
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gtk-engines
+ standalone? (
+ media-fonts/roboto
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+"
+
+S="${WORKDIR}/${P}/trunk"
+
+DOCS=( changelog README )
+
+src_configure() {
+ local myconf=(
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex standalone "" "--no-standalone")
+ $(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
+}