summaryrefslogtreecommitdiff
path: root/media-sound/guitarix/guitarix-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /media-sound/guitarix/guitarix-9999.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'media-sound/guitarix/guitarix-9999.ebuild')
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
index a9962b2bb430..95daa28f6cff 100644
--- a/media-sound/guitarix/guitarix-9999.ebuild
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE='threads(+)'
@@ -10,8 +11,9 @@ inherit python-any-r1 waf-utils xdg git-r3
MY_P="${PN}2-${PV}"
DESCRIPTION="Virtual guitar amplifier for Linux"
-HOMEPAGE="http://guitarix.org/"
+HOMEPAGE="https://guitarix.org/"
EGIT_REPO_URI="https://git.code.sf.net/p/guitarix/git"
+S="${WORKDIR}/${P}/trunk"
LICENSE="GPL-2"
SLOT="0"
@@ -21,15 +23,14 @@ REQUIRED_USE="|| ( lv2 standalone )"
COMMON_DEPEND="dev-cpp/eigen:3
dev-cpp/glibmm:2
- dev-cpp/gtkmm:2.4
- dev-lang/sassc
+ dev-cpp/gtkmm:3.0
dev-libs/glib:2
>=media-libs/libsndfile-1.0.17
>=media-libs/zita-convolver-3:=
media-libs/zita-resampler
>=net-misc/curl-7.26.0
>=sci-libs/fftw-3.1.2:3.0=
- x11-libs/gtk+:2
+ x11-libs/gtk+:3
lv2? ( media-libs/lv2 )
standalone? (
dev-libs/boost:=
@@ -40,21 +41,22 @@ COMMON_DEPEND="dev-cpp/eigen:3
zeroconf? ( net-dns/avahi )
)
"
-# clearlooks gtk engine and roboto fonts are required for correct ui rendering
+# roboto fonts are required for correct ui rendering
RDEPEND="${COMMON_DEPEND}
- x11-themes/gtk-engines
standalone? (
media-fonts/roboto
)
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
+ dev-lang/sassc
virtual/pkgconfig
- nls? ( dev-util/intltool )
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
"
-S="${WORKDIR}/${P}/trunk"
-
DOCS=( changelog README )
src_configure() {