summaryrefslogtreecommitdiff
path: root/media-sound/grip/grip-3.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 23:54:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 23:54:25 +0000
commitf443475c824b4b5c086e6d040961cb35ad81bc60 (patch)
tree6a6b4078e5565d11ab153a37a39af2d57becea34 /media-sound/grip/grip-3.6.2.ebuild
parent407525b571b48cfd65e1ad7a02d250a927c967c9 (diff)
gentoo resync : 02.12.2017
Diffstat (limited to 'media-sound/grip/grip-3.6.2.ebuild')
-rw-r--r--media-sound/grip/grip-3.6.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/grip/grip-3.6.2.ebuild b/media-sound/grip/grip-3.6.2.ebuild
new file mode 100644
index 000000000000..5f7555472651
--- /dev/null
+++ b/media-sound/grip/grip-3.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs libtool
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ gnome-base/libgnome
+ >=gnome-base/libgnomeui-2.2.0
+ >=media-libs/id3lib-3.8.3
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ >=x11-libs/gtk+-2.2:2
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/vte:0
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ sed '/^Icon/s@grip\b@gripicon@' -i grip.desktop || die
+}
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}