summaryrefslogtreecommitdiff
path: root/media-sound/gnump3d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-23 09:48:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-23 09:48:32 +0100
commit7795d9198ccb546ad792af2694399b516fc244ac (patch)
tree0f80cd898370b3bbd31dad1b53588d38064793c6 /media-sound/gnump3d
parent76639e956cb332de1bfbf50143f11084d2686c65 (diff)
gentoo auto-resync : 23:08:2023 - 09:48:32
Diffstat (limited to 'media-sound/gnump3d')
-rw-r--r--media-sound/gnump3d/Manifest1
-rw-r--r--media-sound/gnump3d/gnump3d-3.0-r5.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/gnump3d/Manifest b/media-sound/gnump3d/Manifest
index a8da750969a0..91fb89b907a6 100644
--- a/media-sound/gnump3d/Manifest
+++ b/media-sound/gnump3d/Manifest
@@ -2,4 +2,5 @@ AUX gnump3d.conf.d 159 BLAKE2B d03de16b977c8c892be3dcd6ec7b45414dac9694a777fde57
AUX gnump3d.init.d-r1 826 BLAKE2B 37e9ea5403584881c2a4d87460fa058464eac1a1342af0decec37149f682b4946bb9cf34dc8eff21e6cd83c03aa2a334a8fbe2d9f7c9afd77194897b914dec20 SHA512 c54609e031615cf84328e52ed44d2744391abc580c19df512a62ff8e9091f52eea3741748559fe22f995cedc7d47bb12ea5bd0f5851bf4706327a8fd24d17309
DIST gnump3d-3.0.tar.bz2 633215 BLAKE2B aec3e2e95ebcbf2b9465f8f7e5cf579fe64e9e48d3b1757f78d3102f3a02f92970cbccc5986741013505e1b2f0e54e0d7a7c3871837c6169898e763f23e7fcca SHA512 23778604b557346e42f5cd2045cc394c7d6f7044479c74cd635dfdbbfd6835c8e3ad761d54c5cba239cc5e020b049ac11d64eb463272fc4134b7645226e2524b
EBUILD gnump3d-3.0-r4.ebuild 1889 BLAKE2B 4e6cb3bc6dedcc7a4457a54667b3bbf973b171cb79632d526787d4a0a0a37315c9ae4b86223d4b8f332f1977258ac8dba8f259702135c83f235e8ac1edda1cda SHA512 101c6fa5cc4a54a246df1b37a5ae12e20db1643dd62d20fdc315815567bb65df5271030d3a95e14f8c489a24221f2c318c0648012d583206e8982deeba1c82aa
+EBUILD gnump3d-3.0-r5.ebuild 1915 BLAKE2B e1e72c0c396555a6781aaec31eacdd73690df932e092187d450f8d5fc4288623585b19feedf86c2de6a7029422068dbb3bb12190bdb094d694888cc53f2015c2 SHA512 70cef9caf1d94631851bb6beb6f73f55ea14aba8fa36256bc147625d87384dc2f190a50b8f7fd44c0a2c9c73b185ea6d7f64b42007c930f5849283e005d7ce1a
MISC metadata.xml 250 BLAKE2B 3e6dae5d5f3b3ac412806dd8615a1975c7ea8a64bfd72ad54f2c93a9b24c19c620ac3e8b26e1f6cadec899443e138ee4fb7a82ecb83c784d0c03ee91854d8622 SHA512 2bfce2cf73aefce6dda06ea351cb93b2990b9543f48be1ae5406a5a5acf2c34faed1eb2ce715eb689eb50a9a1add5576b39232eb818c233f5a5589e16032aca8
diff --git a/media-sound/gnump3d/gnump3d-3.0-r5.ebuild b/media-sound/gnump3d/gnump3d-3.0-r5.ebuild
new file mode 100644
index 000000000000..79be656f708f
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-3.0-r5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Streaming server for MP3, OGG vorbis and other streamable files"
+HOMEPAGE="https://www.gnu.org/software/gnump3d/"
+SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ || ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="sox"
+
+DEPEND="
+ acct-group/gnump3d
+ acct-user/gnump3d
+"
+
+RDEPEND="
+ ${DEPEND}
+ sox? ( media-sound/sox )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_compile() { :; }
+
+src_install() {
+ perl_set_version
+
+ insinto "${VENDOR_LIB}"/gnump3d
+ doins lib/gnump3d/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+ insinto "${VENDOR_LIB}"/gnump3d/lang
+ doins lib/gnump3d/lang/*.pm
+
+ dobin bin/gnump3d2 bin/gnump3d-top bin/gnump3d-index
+ dosym gnump3d2 /usr/bin/gnump3d
+ doman man/*.1
+
+ insinto /usr/share/gnump3d
+ doins -r templates/*
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types etc/file.types
+ sed -e "s,PLUGINDIR,${VENDOR_LIB},g" -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+ sed -e 's,^user *= *\(.*\)$,user = gnump3d,g' -i "${ED}/etc/gnump3d/gnump3d.conf" || die
+
+ dodoc AUTHORS ChangeLog DOWNSAMPLING PLUGINS README SUPPORT TODO
+
+ newinitd "${FILESDIR}"/${PN}.init.d-r1 gnump3d
+ newconfd "${FILESDIR}"/${PN}.conf.d gnump3d
+
+ keepdir /var/log/gnump3d
+ fowners gnump3d:gnump3d /var/log/gnump3d
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/gnump3d/gnump3d.conf before running"
+ elog "/etc/init.d/gnump3d start"
+ elog ""
+ elog "At the very least, you will need to change the root directory"
+ elog "where music is found. By default, gnump3d will also listen"
+ elog "to any address on port 8888"
+ elog ""
+ elog "You can optionally use sox to downmix the quality of streamed"
+ elog "music in realtime for slow connections."
+}