summaryrefslogtreecommitdiff
path: root/media-sound/gnome-music
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /media-sound/gnome-music
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest2
-rw-r--r--media-sound/gnome-music/gnome-music-42.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index e2cc08790a66..0b0acd41c962 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1,4 +1,6 @@
AUX 40.1.1-fix-build-with-meson-0.61.1.patch 941 BLAKE2B b55eeaf227b092e11855fbd00ffadb3bc63c8cecb4689ea23351b525f4c8d1452b772edb344c07b6533b2831451e3c522f76290b85314e8db8760559f8c2aaab SHA512 a0e2940c11f8513b501e9f3561e68cbee93932a8b4ef967513399267b21f307b8b7a27eb1ffe89f6edfedf9e36f15a517dbef3fd3c0c4fc8d169356a80e7bbbe
DIST gnome-music-41.0.tar.xz 898652 BLAKE2B cc72eb7be553ccefe10620a85aa3ee75aa30c1809e810a8ebb30a2ffbccebb9dc173cc79859e098be97fea9c964f0f6969f55c7c84ea9540a93a920376746ac1 SHA512 883f8862d5216ab30c3208a316378c2ef016ba52861c9261b8fa9ceb44f935e4dc35608ea66b333c3bf61c9dcc950fa338adfadc2d5e7f67a7a84467228d28a2
+DIST gnome-music-42.0.tar.xz 1651960 BLAKE2B 43ecee648441dab0b562e5a307554e62b3aac5f55f798bbcdbf99c50fd034b5fe52f9fafcac95a0e12e910499618337e37042ca7482e313b3854ed708f4f4cde SHA512 2e104188681337d200fabdfb2a332e4c01c8c0357580fc6f8c53fa0e44ebc4785c33acf0b32f201cad0acdfc0cb4a6dcf21b15842d0aa0b480add5f91d2a46e7
EBUILD gnome-music-41.0.ebuild 2038 BLAKE2B 320ae70e53fbf0fd10d422c9474e8ad51e9fec306d44286fbf00cb204b4b7bdfdbf1b3353e34d233e7dde1f99dda502874c3fcb4afa6c7ed59c43797b5d68275 SHA512 c39ca3701a2d60bb50c410159307ef08eda5af203e13fc1d023bc003578d15d3cfd04081d3aba6b429bc03305dd7db3a20c079c04db1623d3b69837d995a1e82
+EBUILD gnome-music-42.0.ebuild 1849 BLAKE2B 3d05926c2893b92f9364e5e1117edb7bc344119488e89c6c43fcb0c84c07eb114f5f279f19083841dfc8ae091592543590402f49aee1679bd5416c9abeffa450 SHA512 c8b1f5e332642b3c3ad34893f80da7620b458707303509bc00b6df1ef1f03ea054307cfe1dd9f082d95f931a5ce97fc20e588c446c00e670578026b25a0f4cfe
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/media-sound/gnome-music/gnome-music-42.0.ebuild b/media-sound/gnome-music/gnome-music-42.0.ebuild
new file mode 100644
index 000000000000..1ca03facd942
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-42.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music https://gitlab.gnome.org/GNOME/gnome-music/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.67.1:2
+ >=net-libs/gnome-online-accounts-3.35.90[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=gui-libs/gtk-4.5.0:4[introspection]
+ >=gui-libs/libadwaita-1.0:1=[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:2.4[introspection]
+ app-misc/tracker:3=[introspection(+)]
+ >=x11-libs/pango-1.44:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.13:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.13:0.3
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ app-misc/tracker-miners:3[gstreamer]
+ app-misc/tracker-miners:3[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}