summaryrefslogtreecommitdiff
path: root/media-sound/gnome-music
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 05:02:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 05:02:24 +0100
commit58018a2c9504435bb719f2d60439ebe22fbeb503 (patch)
tree7c4241c639fcf98d0a61506786b8b3be9bfef48d /media-sound/gnome-music
parent5017c48e54de7e3dcebd1db96598cf0a07b21f16 (diff)
gentoo auto-resync : 17:09:2023 - 05:02:24
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest2
-rw-r--r--media-sound/gnome-music/gnome-music-45.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 6dd4e89159f2..c41813070fe8 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1,3 +1,5 @@
DIST gnome-music-44.0.tar.xz 1662928 BLAKE2B 3d9abcff6d4a220582974675c2966316259d01d0e34e805e8a9b6899f8ba44b5e70e7613c522c01bb831e0c966eb9181e7714b3226401453b34210a1322d81de SHA512 42985d13de8df838cd6beab8edc0d7c1a66c0018dbfcac2551779964194782efd2c6c6bc79c10e3bd1f8eb0a73cb783b51440338d7ff025e4e42d9196b78a847
+DIST gnome-music-45.0.tar.xz 1662996 BLAKE2B dedcb905ad135bd9bff569cb1168062e0f451479e00cddc3ac56dc506b938a090c1189495ee79b563a7e045e45cde40eb5095f4085c0a7de36fa1b876bc312f9 SHA512 9f919a3dd63826e7c31c57d62fbdd0dad463d401e213ca8aa119357d7203449ddd5b10b03d3ac66008399fadd6afcb3f7ae52b21fa9bf3f5c79eca6e859f67cc
EBUILD gnome-music-44.0.ebuild 1858 BLAKE2B 3069433dab07fe4f977310284948853a128a45dc398adb16b37243c4b3c140cd0c87ffa054065fd787bc5c7ff9abf5065719de729abe8bbcdf87a6c550766c5f SHA512 c44405e7758b5ab87a42d84f605bbb60caa6e312048fc509d439a51252a175eaeb30283512b218d7d64840b976e7979a44f2bd1380a1a7dbaba8a05da51fa464
+EBUILD gnome-music-45.0.ebuild 1862 BLAKE2B 0c676899737237df0e5ff0c70b16c2deedc47088ec1c31532e97e38a9505f2d89ffb8c9e122f1ac9e8661ae907e7314fcf3f6207ec530a93485dc48a4b60eaa5 SHA512 69b7b7700724137d29cebdbc4d40f6d8c82053ac7e4944e948756a7c8f4e9e24626635b051082666a2506c8293eaddbc4ea5cda2969dcaf7a3d52c4caa28ac7a
MISC metadata.xml 352 BLAKE2B 8f9983c2cfeccb1a920be308931a9eef0700560f7c7a249fbf0a8d450467d77b670c6de9e3a3ef470933fd10a4e9190314c7a98470064addef7667dc2d19c92e SHA512 eaa3bfbb8fb4078c94f9b0300d3574345138899056cb3e9ba114448728f347a0cbdc45aea2b3501bb85dc459eeccc4e2f1f56212a4982d99d9113732bc17998c
diff --git a/media-sound/gnome-music/gnome-music-45.0.ebuild b/media-sound/gnome-music/gnome-music-45.0.ebuild
new file mode 100644
index 000000000000..d5e99af71213
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-45.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music https://gitlab.gnome.org/GNOME/gnome-music/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.67.1:2
+ >=net-libs/gnome-online-accounts-3.35.90[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=gui-libs/gtk-4.5.0:4[introspection]
+ >=gui-libs/libadwaita-1.2:1=[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:3.0[introspection]
+ app-misc/tracker:3=[introspection(+)]
+ >=x11-libs/pango-1.44:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.15-r1:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.16:0.3[tracker]
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ app-misc/tracker-miners:3[gstreamer]
+ app-misc/tracker-miners:3[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}