summaryrefslogtreecommitdiff
path: root/media-sound/gnome-music
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /media-sound/gnome-music
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'media-sound/gnome-music')
-rw-r--r--media-sound/gnome-music/Manifest2
-rw-r--r--media-sound/gnome-music/gnome-music-3.36.7.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 05820d4e7b76..94675d38c543 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1,3 +1,5 @@
DIST gnome-music-3.36.4.1.tar.xz 979064 BLAKE2B e744bee915a48a5d2366350cda7ebb0c43382f46de07d9203d95675cad45d825f2d93cc07be7865eceb5be3554ab478ecf84c52d9b8f5defc198b4f1b6638926 SHA512 8b6b4a8a44158a724de82855ba781dd6ceb53a30a35160f477721a385a841697f9a7c97cdba9a5bcc5b36834d55c034eb4c892907d550205dc5b7f7af56133ca
+DIST gnome-music-3.36.7.tar.xz 971980 BLAKE2B f27d0eb49a1728873ef6d439eead83cc34fb6802afdba3b4e0ef8d15c88d2012634ec0a18a4df4ba18079915d4227f526a93ac7989ce6ea4a807b620722fad1e SHA512 3470563621c17004d0b92451950ebfca203e830cb9ffe481fef7fe4d5187afa36ccb33130695226d4db95a89af9fac592910d2a19e715af4dd0c0ffba081c3a4
EBUILD gnome-music-3.36.4.1.ebuild 2045 BLAKE2B 6e3adace7160f1aa9a1d6ad9d3c36158326e3c055ac21a7c465e4e2d31e35c1ad06d001a21519b32fc745e56eec137d1533de54351dd267be3ed3476c15b29ac SHA512 817d8419483d631160fcf4bead6a54b6505f00422d2feba1445a8153ae29a94ba1cde7729117065d545d6148fcae6d68542016f79caf111be9e911feab113017
+EBUILD gnome-music-3.36.7.ebuild 2047 BLAKE2B c00989998335746d9afe6e9a81094a4d6af3e9e3b8972cc5c0822fe47d380ee6ebd267cc18c40c2c2cf090c33d4794577d21359afe67123013eea5cf332cede7 SHA512 e3ca6d511b0865946eb4f9193f2dea40344ac730782fa6a891bbeb599fba6c5844acc3dc5b9e63570b3b92e55cc9453bca3be2ffc0bf88f7cafd5af011273887
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/media-sound/gnome-music/gnome-music-3.36.7.ebuild b/media-sound/gnome-music/gnome-music-3.36.7.ebuild
new file mode 100644
index 000000000000..333450fc479b
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-3.36.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ >=net-libs/gnome-online-accounts-3.35.90[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=x11-libs/gtk+-3.24.7:3[introspection]
+ >=dev-libs/libdazzle-3.28.0[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:2.4[introspection]
+ >=app-misc/tracker-2.3.0:=[introspection(+)]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.29.1:3[cairo,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.12:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.10:0.3
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ >=app-misc/tracker-miners-2.2.0[gstreamer]
+ >=app-misc/tracker-miners-2.2.0[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="test" # only does desktop and appdata validation, and latter needs network to validate screenshot from https
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ sed -e '/sys.path.insert/d' -i "${S}"/gnome-music.in || die "python fixup sed failed"
+ xdg_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}