summaryrefslogtreecommitdiff
path: root/media-sound/gmpc/gmpc-11.8.16-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/gmpc/gmpc-11.8.16-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/gmpc/gmpc-11.8.16-r1.ebuild')
-rw-r--r--media-sound/gmpc/gmpc-11.8.16-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/gmpc/gmpc-11.8.16-r1.ebuild b/media-sound/gmpc/gmpc-11.8.16-r1.ebuild
new file mode 100644
index 000000000000..9629d477e07a
--- /dev/null
+++ b/media-sound/gmpc/gmpc-11.8.16-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+VALA_MIN_API_VERSION=0.12
+
+inherit autotools eutils gnome2-utils vala
+
+DESCRIPTION="A GTK+2 client for the Music Player Daemon"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Gnome_Music_Player_Client"
+SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls xspf +unique"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ >=media-libs/libmpd-11.8
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ x11-themes/hicolor-icon-theme
+ unique? ( dev-libs/libunique:1 )
+ xspf? ( >=media-libs/libxspf-1.2 )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/gnome-doc-utils
+ >=dev-util/gob-2.0.17
+ virtual/pkgconfig
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch \
+ "${FILESDIR}"/${P}-icons.patch
+ sed -i -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:" configure.ac || die
+ eautoreconf
+ vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-libspiff \
+ --disable-appindicator \
+ --enable-mmkeys \
+ $(use_enable nls) \
+ $(use_enable unique) \
+ $(use_enable xspf libxspf)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }