summaryrefslogtreecommitdiff
path: root/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-3.1.3.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild b/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
new file mode 100644
index 000000000000..e600ca8d596b
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 xdg
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/python-ly[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ media-sound/lilypond"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}