summaryrefslogtreecommitdiff
path: root/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/frescobaldi/frescobaldi-2.0.16.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-2.0.16.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-2.0.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild b/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild
new file mode 100644
index 000000000000..9fdc9d8b1475
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain" # public-domain is for bundled Tango icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portmidi"
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2
+ portmidi? ( media-libs/portmidi )"
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}