summaryrefslogtreecommitdiff
path: root/media-sound/fmdrv/fmdrv-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /media-sound/fmdrv/fmdrv-1.0.7.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'media-sound/fmdrv/fmdrv-1.0.7.ebuild')
-rw-r--r--media-sound/fmdrv/fmdrv-1.0.7.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/media-sound/fmdrv/fmdrv-1.0.7.ebuild b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
index e4701c3430f5..9cb17380f290 100644
--- a/media-sound/fmdrv/fmdrv-1.0.7.ebuild
+++ b/media-sound/fmdrv/fmdrv-1.0.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Console mode MIDI player with builtin userland OPL2 driver"
HOMEPAGE="https://bisqwit.iki.fi/source/fmdrv.html"
@@ -12,23 +13,21 @@ LICENSE="fmdrv GPL-2" # GPL-2 only
SLOT="0"
KEYWORDS="amd64 x86"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ioperm.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-ioperm.patch
+ "${FILESDIR}"/${P}-fix-makefile.patch
+)
-src_configure() { :; } # it is a fake
+DOCS=( README )
+HTML_DOCS=( README.html )
-src_compile() {
- emake fmdrv \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export AR CC CXX
}
src_install() {
dobin fmdrv
- dodoc README
- dohtml README.html
+ einstalldocs
}
pkg_postinst() {