summaryrefslogtreecommitdiff
path: root/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild')
-rw-r--r--media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild b/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild
new file mode 100644
index 000000000000..dd602b835a27
--- /dev/null
+++ b/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="The Fluid R3 soundfont"
+HOMEPAGE="http://musescore.org/en/handbook/soundfont"
+SRC_URI="http://prereleases.musescore.org/soundfont/${PN}_${PV}.tar.gz
+ timidity? ( https://dev.gentoo.org/~hwoarang/distfiles/timidity.cfg.bz2 )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="timidity"
+
+RDEPEND="timidity? ( app-eselect/eselect-timidity )"
+
+src_install() {
+ insinto /usr/share/sounds/sf2
+ doins FluidR3_GM.sf2 FluidR3_GS.sf2
+
+ dodoc README
+
+ if use timidity; then
+ insinto /usr/share/timidity/${PN}
+ doins "${WORKDIR}"/timidity.cfg
+ fi
+}