summaryrefslogtreecommitdiff
path: root/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild')
-rw-r--r--media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild b/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
new file mode 100644
index 000000000000..79edbc44d76c
--- /dev/null
+++ b/media-sound/entagged-tageditor/entagged-tageditor-0.35.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Open-source audiofile tagger"
+HOMEPAGE="http://entagged.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/squareness-jlf
+ dev-db/hsqldb"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-db/hsqldb"
+
+EANT_BUILD_XML="entagged/build.xml"
+EANT_BUILD_TARGET="build"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p test/entagged/junit || die
+ mv entagged/entagged/junit test/entagged || die
+ rm entagged/*.jar || die
+ java-pkg_jarfrom hsqldb hsqldb.jar entagged/hsqldb.jar
+ cd entagged || die
+ epatch "${FILESDIR}"/${P}-buildfixes.patch
+}
+
+src_install() {
+ cd entagged || die
+ java-pkg_newjar ${P}.jar ${PN}.jar
+ java-pkg_register-dependency squareness-jlf
+ java-pkg_dolauncher ${PN} --main entagged.tageditor.TagEditorFrameSplash
+ newicon entagged/tageditor/resources/icons/entagged-icon.png ${PN}.png
+ make_desktop_entry ${PN} "Entagged Tag Editor" ${PN}
+}