summaryrefslogtreecommitdiff
path: root/media-sound/din/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-16 16:18:18 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-16 16:18:18 +0000
commit0704956f7256f1f618cc5e03af2c1dbd0e83dbc5 (patch)
tree881671532c0c3c82ebd4523b6d6cbc8ace982aae /media-sound/din/files
parent21435953e16cda318a82334ddbadb3b5c36d9ea7 (diff)
gentoo resync : 16.01.2020
Diffstat (limited to 'media-sound/din/files')
-rw-r--r--media-sound/din/files/din-5.2.1-desktop.patch8
-rw-r--r--media-sound/din/files/din-5.2.1-makefile.patch10
-rw-r--r--media-sound/din/files/din-5.2.1-tcl.patch11
-rw-r--r--media-sound/din/files/fix-random-constants.patch30
4 files changed, 0 insertions, 59 deletions
diff --git a/media-sound/din/files/din-5.2.1-desktop.patch b/media-sound/din/files/din-5.2.1-desktop.patch
deleted file mode 100644
index e9bd7a62bc56..000000000000
--- a/media-sound/din/files/din-5.2.1-desktop.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- din-5.2.1/data/din.desktop
-+++ din-5.2.1/data/din.desktop
-@@ -8,4 +8,4 @@
- StartupNotify=true
- Terminal=false
- Type=Application
--Categories=Application;AudioVideo;Audio;Midi;Music;
-+Categories=AudioVideo;Audio;Midi;Music;
diff --git a/media-sound/din/files/din-5.2.1-makefile.patch b/media-sound/din/files/din-5.2.1-makefile.patch
deleted file mode 100644
index 1f79f82ce495..000000000000
--- a/media-sound/din/files/din-5.2.1-makefile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- din-5.2.1/src/Makefile.am
-+++ din-5.2.1/src/Makefile.am
-@@ -1,5 +1,5 @@
--AM_CXXFLAGS = $(liblo_CFLAGS) $(jack_CFLAGS) $(fftw3f_CFLAGS) -I /usr/include -I /usr/local/include -I /opt/include -I/usr/include/tcl8.5 -I/usr/local/include/tcl8.5 -I /opt/include/tcl8.5 -I ../include -Wall -O3
--LIBS += $(liblo_LIBS) $(jack_LIBS) $(fftw3f_LIBS) -L/usr/lib/tcl8.5 -L/usr/local/lib/tcl8.5 -L /opt/lib/tcl8.5 -L /usr/lib -L /opt/lib -L /usr/local/lib -ltcl8.5 -lGL -lircclient -lrt -lX11
-+AM_CXXFLAGS = $(liblo_CFLAGS) $(jack_CFLAGS) $(fftw3f_CFLAGS) -I /usr/include -I ../include -Wall
-+LIBS += $(liblo_LIBS) $(jack_LIBS) $(fftw3f_LIBS) -ltcl -lGL -lircclient -lrt -lX11
-
- bin_PROGRAMS = din
-
diff --git a/media-sound/din/files/din-5.2.1-tcl.patch b/media-sound/din/files/din-5.2.1-tcl.patch
deleted file mode 100644
index a5582f1bba15..000000000000
--- a/media-sound/din/files/din-5.2.1-tcl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- din-5.2.1/configure.ac
-+++ din-5.2.1/configure.ac
-@@ -3,7 +3,7 @@
- AC_CONFIG_SRCDIR([configure.ac])
- AC_PROG_CXX
- AC_CHECK_HEADERS([GL/gl.h],AC_MSG_NOTICE([+++ Found OpenGL +++]),[AC_MSG_ERROR([!!! Please install OpenGL !!!])])
--AC_CHECK_HEADERS([tcl.h] [tcl8.5/tcl.h],AC_MSG_NOTICE([+++ Found Tcl 8.5 +++]),[AC_MSG_WARN([!!! Is Tcl 8.5 installed? !!!])])
-+AC_CHECK_HEADERS([tcl.h], AC_MSG_NOTICE([+++ Found Tcl +++]),[AC_MSG_ERROR([!!! Please install Tcl !!!])])
- AC_CHECK_HEADERS([libircclient/libircclient.h],,[AC_MSG_ERROR([!!! Please install libircclient !!!])])
- PKG_CHECK_MODULES([liblo], [liblo])
- PKG_CHECK_MODULES([jack], [jack])
diff --git a/media-sound/din/files/fix-random-constants.patch b/media-sound/din/files/fix-random-constants.patch
deleted file mode 100644
index f055b10140d6..000000000000
--- a/media-sound/din/files/fix-random-constants.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Description: Redefine some constants in include/random.h as unsigned
- These constants are used with unsigned variables, so redefine them
- for consistency.
- .
- This also fixes compilation errors under C++11: In C++11, array initialization
- is considered list initialization and so prohibits narrowing conversions
- (from negative signed values to unsigned).
-Author: Philip Chung <philipchung1995@yahoo.com>
-Bug-Debian: https://bugs.debian.org/811778
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
----
- include/random.h | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- din-5.2.1.orig/include/random.h
-+++ din-5.2.1/include/random.h
-@@ -28,9 +28,9 @@
-
- const int N = 624;
- const int M = 397;
--const int MATRIX_A = 0x9908b0df; /* constant vector a */
--const int UPPER_MASK = 0x80000000; /* most significant w-r bits */
--const int LOWER_MASK = 0x7fffffff; /* least significant r bits */
-+const unsigned int MATRIX_A = 0x9908b0df; /* constant vector a */
-+const unsigned int UPPER_MASK = 0x80000000; /* most significant w-r bits */
-+const unsigned int LOWER_MASK = 0x7fffffff; /* least significant r bits */
-
- static unsigned int mt[N]; /* the array for the state vector */
- static int mti=N+1; /* mti==N+1 means mt[N] is not initialized */