summaryrefslogtreecommitdiff
path: root/media-sound/darkice/darkice-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/darkice/darkice-1.4.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/darkice/darkice-1.4.ebuild')
-rw-r--r--media-sound/darkice/darkice-1.4.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/darkice/darkice-1.4.ebuild b/media-sound/darkice/darkice-1.4.ebuild
new file mode 100644
index 000000000000..0c54f4f70ac0
--- /dev/null
+++ b/media-sound/darkice/darkice-1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A live audio streamer"
+HOMEPAGE="http://www.darkice.org/"
+SRC_URI="https://github.com/rafael2k/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="aac aacplus alsa debug jack libsamplerate mp3 opus pulseaudio twolame vorbis"
+
+RDEPEND="aac? ( media-libs/faac )
+ aacplus? ( media-libs/libaacplus )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ libsamplerate? ( media-libs/libsamplerate )
+ mp3? ( media-sound/lame )
+ opus? ( media-libs/opus )
+ pulseaudio? ( media-sound/pulseaudio )
+ twolame? ( media-sound/twolame )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( aac aacplus mp3 opus twolame vorbis )
+ || ( alsa jack pulseaudio )"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README TODO )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with aac faac)
+ $(use_with aacplus)
+ $(use_with alsa)
+ $(use_with jack)
+ $(use_with libsamplerate samplerate)
+ $(use_with mp3 lame)
+ $(use_with opus)
+ $(use_with pulseaudio)
+ $(use_with twolame)
+ $(use_with vorbis)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ einstalldocs
+}