summaryrefslogtreecommitdiff
path: root/media-sound/coquillo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-28 06:30:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-28 06:30:54 +0000
commit72fd2b48b7154274a1d2009cdaab54e7f49fb3aa (patch)
tree9c6ce981e8f924eb5f24e71e13c91b37aafb8616 /media-sound/coquillo
parent721e451ec418e1712f6962404e111f0ebd487389 (diff)
gentoo auto-resync : 28:12:2024 - 06:30:54
Diffstat (limited to 'media-sound/coquillo')
-rw-r--r--media-sound/coquillo/Manifest3
-rw-r--r--media-sound/coquillo/coquillo-2.0.1-r1.ebuild (renamed from media-sound/coquillo/coquillo-2.0.1.ebuild)6
-rw-r--r--media-sound/coquillo/files/coquillo-2.0.1-fix-build-taglib2.patch9
3 files changed, 15 insertions, 3 deletions
diff --git a/media-sound/coquillo/Manifest b/media-sound/coquillo/Manifest
index 8865590b0eee..9e7eb726ba5e 100644
--- a/media-sound/coquillo/Manifest
+++ b/media-sound/coquillo/Manifest
@@ -1,3 +1,4 @@
+AUX coquillo-2.0.1-fix-build-taglib2.patch 253 BLAKE2B 4827e8f69e10825d2a2a268efff848c59cc982893d45d4d4acf786bd7756788c6c091f43c81e8349d018cc408999538f752b8a9ef7b7774713249ef1c9175e7a SHA512 c3a7f982e2b0e6002290a38e1bfaf2a93880caacaf288474d985116dfca558128e4377388a5b1cb732e8addf4358a5bb7740950b5d1404c0b7120af3420f32fc
DIST coquillo-2.0.1.tar.gz 76376 BLAKE2B a2f4742eefb8e09203106aa57257ebed343371c3276cab5b49f277d8f9ffd0f5aa242ac9337341dfdb798213604790c3891b403cfe8589902956b365c0ddde2c SHA512 6aeeca674180038089d3f1104cfe9d8d662ed88a6168b20c18932c4329ccfa895508c2e593cab274b51251e2b6b45ca5482c2385ce0e0ddc2b5b1859ee8a3eb5
-EBUILD coquillo-2.0.1.ebuild 731 BLAKE2B a55de8a3e70a8b87733911201e16eb13660c254279a5b4d764bb3b8b4311d56442523fe31d57bd20d49fd3c2cf38be252cacb55494adac57d6c1ae2eb75e57f7 SHA512 598e8ecbf02416f6da2e374c1137f94047d271e9c42ee2201cb40572ec5cd717f75546750f3a78a78df27dcd02e7fd752ad2f9af0266884f41b0e5af74db3216
+EBUILD coquillo-2.0.1-r1.ebuild 796 BLAKE2B b1798ef99251ba17a50fe242f9ff797156740b09110a584b6f8b630ebd03daeb61c89c0dbc1d2c172b68c3a65b88d37d659261ecded1a411b6bed64a3b4b8369 SHA512 eb1dd11d5e03767d0d080bc9b99d68b5c5922886cb7909b5ffaad629bbce1be3908c6ee5644931e34f1188227e3497af8d2ec47d156c19054e8f0024fc18387f
MISC metadata.xml 260 BLAKE2B 9945ac40ee60ce67adf51840c3cc2d6d2743dffe4fd2ec965d300c709323f80eb5d35eaeb804414eebb2da1e954ee688067c05093b26499678de524b414ac4ec SHA512 e5b6a2a44cd2a4ea4fb1267eb8f635c079c022853443ad180ca12f2df84492f3ba34db45e4ff5e7e09262a74745f5c0aa04ebccd6f998cf19a6ea2ccd0627701
diff --git a/media-sound/coquillo/coquillo-2.0.1.ebuild b/media-sound/coquillo/coquillo-2.0.1-r1.ebuild
index 58e806189020..d638dd4c1613 100644
--- a/media-sound/coquillo/coquillo-2.0.1.ebuild
+++ b/media-sound/coquillo/coquillo-2.0.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop qmake-utils
@@ -21,10 +21,12 @@ DEPEND="
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
media-libs/musicbrainz:5=
- media-libs/taglib
+ media-libs/taglib:=
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${PN}-2.0.1-fix-build-taglib2.patch )
+
src_configure() {
eqmake5
}
diff --git a/media-sound/coquillo/files/coquillo-2.0.1-fix-build-taglib2.patch b/media-sound/coquillo/files/coquillo-2.0.1-fix-build-taglib2.patch
new file mode 100644
index 000000000000..62303e0919b8
--- /dev/null
+++ b/media-sound/coquillo/files/coquillo-2.0.1-fix-build-taglib2.patch
@@ -0,0 +1,9 @@
+https://github.com/sjuvonen/coquillo/pull/12.patch
+--- a/src/crawler/tag/xiphcomment.cpp
++++ b/src/crawler/tag/xiphcomment.cpp
+@@ -1,4 +1,5 @@
+
++#include <taglib/taglib.h>
+ #include <taglib/xiphcomment.h>
+ #include <QImage>
+ #include "xiphcomment.hpp"