summaryrefslogtreecommitdiff
path: root/media-sound/cmusfm/cmusfm-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 10:26:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 10:26:59 +0100
commit870be9524d5a85e6be7803b3f4eae71fd93cb530 (patch)
tree69e71d2202044c302e1f9209a0a40d7418d8e48d /media-sound/cmusfm/cmusfm-0.5.0.ebuild
parent9e8f96c1b33dc01bc5dfbed0cfb2702bb299f1e0 (diff)
gentoo auto-resync : 10:07:2023 - 10:26:59
Diffstat (limited to 'media-sound/cmusfm/cmusfm-0.5.0.ebuild')
-rw-r--r--media-sound/cmusfm/cmusfm-0.5.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/cmusfm/cmusfm-0.5.0.ebuild b/media-sound/cmusfm/cmusfm-0.5.0.ebuild
new file mode 100644
index 000000000000..e891db66beda
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ media-sound/cmus
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}