summaryrefslogtreecommitdiff
path: root/media-sound/cmusfm/cmusfm-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-06 11:18:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-06 11:18:16 +0100
commitebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (patch)
treef2204ce5f94dc3cb13728ff93649d889944952bb /media-sound/cmusfm/cmusfm-0.3.3.ebuild
parentfe1c8b732bd548b699d4c2ef725f67f8b8c8911c (diff)
gentoo resync : 06.05.2018
Diffstat (limited to 'media-sound/cmusfm/cmusfm-0.3.3.ebuild')
-rw-r--r--media-sound/cmusfm/cmusfm-0.3.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/cmusfm/cmusfm-0.3.3.ebuild b/media-sound/cmusfm/cmusfm-0.3.3.ebuild
new file mode 100644
index 000000000000..3a2f2d2e87bf
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+CDEPEND="net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ media-sound/cmus"
+
+src_prepare() {
+ default
+ eautoreconf
+ DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}