summaryrefslogtreecommitdiff
path: root/media-sound/beets/beets-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /media-sound/beets/beets-9999.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'media-sound/beets/beets-9999.ebuild')
-rw-r--r--media-sound/beets/beets-9999.ebuild107
1 files changed, 40 insertions, 67 deletions
diff --git a/media-sound/beets/beets-9999.ebuild b/media-sound/beets/beets-9999.ebuild
index d07f7f6efe20..68328df9060e 100644
--- a/media-sound/beets/beets-9999.ebuild
+++ b/media-sound/beets/beets-9999.ebuild
@@ -4,11 +4,11 @@
EAPI=7
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..8} )
PYTHON_REQ_USE="sqlite"
DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1 bash-completion-r1
+inherit distutils-r1 bash-completion-r1 optfeature
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/beetbox/beets.git"
@@ -26,7 +26,8 @@ HOMEPAGE="https://beets.io/ https://pypi.org/project/beets/"
LICENSE="MIT"
SLOT="0"
-IUSE="badfiles chromaprint cors discogs doc ffmpeg gstreamer icu lastfm mpd replaygain test thumbnail webserver"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
$(python_gen_cond_dep '
@@ -39,54 +40,6 @@ RDEPEND="
dev-python/requests[${PYTHON_MULTI_USEDEP}]
>=dev-python/six-1.9[${PYTHON_MULTI_USEDEP}]
dev-python/unidecode[${PYTHON_MULTI_USEDEP}]
- badfiles? (
- media-libs/flac
- media-sound/mp3val
- )
- chromaprint? (
- dev-python/pyacoustid[${PYTHON_MULTI_USEDEP}]
- media-libs/chromaprint[tools]
- )
- discogs? (
- dev-python/discogs-client[${PYTHON_MULTI_USEDEP}]
- )
- ffmpeg? (
- media-video/ffmpeg:0[encode]
- )
- gstreamer? (
- media-libs/gst-plugins-bad:1.0
- media-libs/gst-plugins-good:1.0
- )
- icu? (
- dev-db/sqlite[icu]
- )
- lastfm? (
- dev-python/pylast[${PYTHON_MULTI_USEDEP}]
- )
- mpd? (
- dev-python/bluelet[${PYTHON_MULTI_USEDEP}]
- dev-python/python-mpd[${PYTHON_MULTI_USEDEP}]
- )
- replaygain? (
- gstreamer? (
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- media-plugins/gst-plugins-libav:1.0
- )
- !gstreamer? ( media-sound/mp3gain )
- )
- thumbnail? (
- dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
- || (
- dev-python/pillow[${PYTHON_MULTI_USEDEP}]
- media-gfx/imagemagick
- )
- )
- webserver? (
- dev-python/flask[${PYTHON_MULTI_USEDEP}]
- cors? (
- dev-python/flask-cors[${PYTHON_MULTI_USEDEP}]
- )
- )
')"
DEPEND="
${RDEPEND}
@@ -97,19 +50,39 @@ BDEPEND="
)
$(python_gen_cond_dep '
test? (
+ dev-db/sqlite[icu]
dev-python/beautifulsoup[${PYTHON_MULTI_USEDEP}]
+ dev-python/bluelet[${PYTHON_MULTI_USEDEP}]
+ dev-python/discogs-client[${PYTHON_MULTI_USEDEP}]
dev-python/flask[${PYTHON_MULTI_USEDEP}]
dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyacoustid[${PYTHON_MULTI_USEDEP}]
+ dev-python/pylast[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/python-mpd[${PYTHON_MULTI_USEDEP}]
dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ || (
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ media-gfx/imagemagick
+ )
dev-python/rarfile[${PYTHON_MULTI_USEDEP}]
dev-python/responses[${PYTHON_MULTI_USEDEP}]
dev-python/wheel[${PYTHON_MULTI_USEDEP}]
+ media-libs/chromaprint[tools]
+ media-libs/flac
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-good:1.0
+ media-sound/mp3val
+ media-sound/mp3gain
+ media-plugins/gst-plugins-libav:1.0
+ media-video/ffmpeg:0[encode]
)
')"
PATCHES=(
"${FILESDIR}/${PV}-0001-compatibility-with-breaking-changes-to-the-ast-modul.patch"
"${FILESDIR}/${PV}-0002-Disable-test_completion.patch"
+ "${FILESDIR}/${PV}-0003-Try-to-work-around-a-Werkzeug-change.patch"
)
DOCS=( README.rst docs/changelog.rst )
@@ -119,6 +92,7 @@ distutils_enable_tests pytest
python_prepare_all() {
distutils-r1_python_prepare_all
+ # Tests that need network
rm test/test_art.py || die "Failed to remove test_art.py"
rm test/test_discogs.py || die "Failed to remove test_discogs.py"
rm test/test_embyupdate.py || die "Failed to remove test_embyupdate.py"
@@ -126,22 +100,6 @@ python_prepare_all() {
rm test/test_spotify.py || die "Failed to remove test_spotify.py"
# Not working and dropped in master
rm test/test_mediafile.py || die "Failed to remove test_mediafile.py"
- if ! use ffmpeg; then
- rm test/test_convert.py || die "Failed to remove test_convert.py"
- fi
- if ! use mpd; then
- rm test/test_player.py || die "Failed to remove test_player.py"
- rm test/test_mpdstats.py || die "Failed to remove test_mpdstats.py"
- fi
- if ! use replaygain; then
- rm test/test_replaygain.py || die "Failed to remove test_replaygain.py"
- fi
- if ! use thumbnail; then
- rm test/test_thumbnails.py || die "Failed to remove test_thumbnails.py"
- fi
- if ! use webserver; then
- rm test/test_web.py || die "Failed to remove test_web.py"
- fi
}
python_compile_all() {
@@ -159,4 +117,19 @@ python_install_all() {
newbashcomp "${T}/beet.bash" beet
insinto /usr/share/zsh/site-functions
newins "${WORKDIR}/${P}/extra/_beet" _beet
+
+ elog "Optional dependencies:"
+ optfeature "badfiles support" "media-libs/flac media-sound/mp3val"
+ optfeature "chromaprint support" "dev-python/pyacoustid media-libs/chromaprint[tools]"
+ optfeature "discogs support" dev-python/discogs-client
+ optfeature "ffmpeg support" media-video/ffmpeg[encode]
+ optfeature "gstreamer support" "media-libs/gst-plugins-bad media-libs/gst-plugins-good"
+ optfeature "icu support" dev-db/sqlite[icu]
+ optfeature "lastfm support" dev-python/pylast
+ optfeature "mpd support" "dev-python/bluelet dev-python/python-mpd"
+ optfeature "replaygain with gstreamer support" "dev-python/pygobject media-plugins/gst-plugins-libav"
+ optfeature "replaygain without gstreamer support" media-sound/mp3gain
+ optfeature "thumbnail support" dev-python/pyxdg "dev-python/pillow media-gfx/imagemagick"
+ optfeature "webserver support" dev-python/flask
+ optfeature "webserver cors support" dev-python/flask-cors
}