summaryrefslogtreecommitdiff
path: root/media-sound/awesfx/awesfx-0.5.1e.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/awesfx/awesfx-0.5.1e.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/awesfx/awesfx-0.5.1e.ebuild')
-rw-r--r--media-sound/awesfx/awesfx-0.5.1e.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/awesfx/awesfx-0.5.1e.ebuild b/media-sound/awesfx/awesfx-0.5.1e.ebuild
new file mode 100644
index 000000000000..1c993f919762
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.1e.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="AWE32 Sound Driver Utility Programs"
+HOMEPAGE="http://ftp.suse.com/pub/people/tiwai/awesfx"
+SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
+
+DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
+
+src_configure() {
+ econf \
+ --with-sfpath=${BANK_LOC}
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/usr/share/sounds/sf2/README-bank
+ newinitd "${FILESDIR}"/sfxload.initd sfxload
+ newconfd "${FILESDIR}"/sfxload.confd sfxload
+}
+
+pkg_postinst() {
+ elog "Copy your SoundFont files from the original CDROM"
+ elog "shipped with your soundcard to ${BANK_LOC}."
+}